Skip to content

← Actionable
Medium, CVSS 6.4

Harbor fails to validate the user permissions when updating a robot account

CVE-2022-31667GHSA-xx9w-464f-7h6f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/goharbor/harbor 2.5.2, 2.4.3, 1.10.13), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:L/A:L
EPSS
  • CVE-2022-31667: 0.52% estimated exploitation activity in the next 30 days; percentile 44.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Harbor fails to validate the user permissions when updating a robot account that belongs to a project that the authenticated user doesn’t have access to. API call: PUT /robots/{robotid} By sending a request that attempts to update a robot account, and specifying a robot account id and robot account name that belongs to a different project that the user doesn’t have access to, it was possible to revoke the robot account permissions. Patches This and similar issues are fixed in Harbor v2.5.2 and later. Please upgrade as soon as possible. Workarounds There are no workarounds available. For more information If you have any questions or comments about this advisory: Open an issue in the Harbor GitHub repository Credits Thanks to Gal Goldstein and Daniel Abeles from Oxeye Security for reporting this issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-xx9w-464f-7h6f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-31667

Advisory: Harbor fails to validate the user permissions when updating a robot account
IDs: CVE-2022-31667, GHSA-xx9w-464f-7h6f
Record: https://patchnext.com/advisories/cve-2022-31667 (revision 1, source checked 26 Oct 2026, 15:08 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/goharbor/harbor 2.5.2, 2.4.3, 1.10.13. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/goharbor/harbor: affected >= 1.0.0, <= 1.10.12; >= 2.0.0, <= 2.4.2; >= 2.5.0, <= 2.5.1; fixed in 1.10.13, 2.5.2, 2.4.3

## Suggested inspection (read-only)
- Go github.com/goharbor/harbor: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/goharbor/harbor.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-xx9w-464f-7h6f (GitHub-reviewed advisory GHSA-xx9w-464f-7h6f lists affected ranges: Go github.com/goharbor/harbor >=1.0.0 =2.0.0 =2.5.0 <=2.5.1)

Commands are suggestions: review each one before running it.

Loading voting…