Harbor fails to validate the user permissions when viewing Webhook policies
CVE-2022-31666GHSA-jf8p-3vjh-pq94
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/goharbor/harbor 2.5.2, 2.4.3, 1.10.13), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 1.0.0, <= 1.10.12>= 2.0.0, <= 2.4.2>= 2.5.0, <= 2.5.1
- Fixed in
- 1.10.13, 2.5.2, 2.4.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jf8p-3vjh-pq94 lists affected ranges: Go github.com/goharbor/harbor >=1.0.0 =2.0.0 =2.5.0 <=2.5.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
- EPSS
- CVE-2022-31666: 0.50% estimated exploitation activity in the next 30 days; percentile 42.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Harbor fails to validate the user permissions to view Webhook policies including relevant credentials configured in different projects the user doesn’t have access to, resulting in malicious users being able to read Webhook policies of other users/projects. API call is GET /projects/{projectnameorid}/webhook/policies/{webhookpolicyid} By sending the below request and specifying different Webhook policy ids in the last part of the URL, the malicious user may disclose Webhook policies related to other repositories/projects.: none;" Patches This and similar issues are fixed in Harbor v2.5.2 and later. Please upgrade as soon as possible. Workarounds There are no workarounds available. For more information If you have any questions or comments about this advisory: Open an issue in the Harbor GitHub repository Credits Thanks to Gal Goldstein and Daniel Abeles from Oxeye Security for reporting this issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-jf8p-3vjh-pq94
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-31666 Advisory: Harbor fails to validate the user permissions when viewing Webhook policies IDs: CVE-2022-31666, GHSA-jf8p-3vjh-pq94 Record: https://patchnext.com/advisories/cve-2022-31666 (revision 1, source checked 26 Oct 2026, 15:05 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/goharbor/harbor 2.5.2, 2.4.3, 1.10.13. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/goharbor/harbor: affected >= 1.0.0, <= 1.10.12; >= 2.0.0, <= 2.4.2; >= 2.5.0, <= 2.5.1; fixed in 1.10.13, 2.5.2, 2.4.3 ## Suggested inspection (read-only) - Go github.com/goharbor/harbor: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/goharbor/harbor. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jf8p-3vjh-pq94 (GitHub-reviewed advisory GHSA-jf8p-3vjh-pq94 lists affected ranges: Go github.com/goharbor/harbor >=1.0.0 =2.0.0 =2.5.0 <=2.5.1) Commands are suggestions: review each one before running it.
Loading voting…