Unsafe deserialisation in the PKI implementation scheme of NVFlare
CVE-2022-31604GHSA-rcxc-3w2m-mp8h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (nvflare 2.1.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI nvflare
- Affected
- < 2.1.2
- Fixed in
- 2.1.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-rcxc-3w2m-mp8h lists affected ranges: PyPI nvflare >=0 <2.1.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rcxc-3w2m-mp8h lists affected ranges: PyPI nvflare >=0 <2.1.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-31604: 2.13% estimated exploitation activity in the next 30 days; percentile 81.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact NVFLARE contains a vulnerability in its PKI implementation module, where The CA credentials are transported via pickle and no safe deserialization. The deserialization of Untrusted Data may allow an unprivileged network attacker to cause Remote Code Execution, Denial Of Service, and Impact to both Confidentiality and Integrity. All versions before 2.1.2 are affected. CVSS Score = 9.8 AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H Patches The patch will be included in nvflare==2.1.2 Workarounds Replace pickle serialization with JSON and change the code accordingly Additional information Issue Found by: Oliver Sellwood (@Nintorac)
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-rcxc-3w2m-mp8h
- Revision 1 · created ·
Published from osv record GHSA-rcxc-3w2m-mp8h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-31604 Advisory: Unsafe deserialisation in the PKI implementation scheme of NVFlare IDs: CVE-2022-31604, GHSA-rcxc-3w2m-mp8h Record: https://patchnext.com/advisories/cve-2022-31604 (revision 2, source checked 26 Oct 2026, 13:12 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: nvflare 2.1.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI nvflare: affected < 2.1.2; fixed in 2.1.2 ## Suggested inspection (read-only) - `python -m pip show nvflare`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on nvflare. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-rcxc-3w2m-mp8h (OSV record GHSA-rcxc-3w2m-mp8h lists affected ranges: PyPI nvflare >=0 <2.1.2 (fixed)) - Verified: https://github.com/advisories/GHSA-rcxc-3w2m-mp8h (GitHub-reviewed advisory GHSA-rcxc-3w2m-mp8h lists affected ranges: PyPI nvflare >=0 <2.1.2) Commands are suggestions: review each one before running it.
Loading voting…