Command injection in Git package in Wrangler
CVE-2022-31249GHSA-qrg7-hfx7-95c5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/rancher/wrangler 1.0.1, 0.8.11, 0.8.5-security1, 0.7.4-security1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/rancher/wrangler
- Affected
- >= 0.8.6, < 0.8.11>= 1.0.0, <= 1.0.0< 0.7.4-security1>= 0.8.0, < 0.8.5-security1
- Fixed in
- 0.7.4-security1, 0.8.5-security1, 1.0.1, 0.8.11
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qrg7-hfx7-95c5 lists affected ranges: Go github.com/rancher/wrangler >=0.8.6 =1.0.0 =0 =0.8.0 <0.8.5-security1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-31249: 3.76% estimated exploitation activity in the next 30 days; percentile 89.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A command injection vulnerability was discovered in Wrangler's Git package affecting versions up to and including v1.0.0. Wrangler's Git package uses the underlying Git binary present in the host OS or container image to execute Git operations. Specially crafted commands can be passed to Wrangler that will change their behavior and cause confusion when executed through Git, resulting in command injection in the underlying host. Workarounds A workaround is to sanitize input passed to the Git package to remove potential unsafe and ambiguous characters. Otherwise, the best course of action is to update to a patched Wrangler version. Patches Patched versions include v1.0.1 and later and the backported tags - v0.7.4-security1, v0.8.5-security1 and v0.8.11. For more information If you have any questions or comments about this advisory: Reach out to SUSE Rancher Security team for security related inquiries. Open an issue in Rancher or Wrangler repository. Verify our support matrix…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-qrg7-hfx7-95c5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-31249 Advisory: Command injection in Git package in Wrangler IDs: CVE-2022-31249, GHSA-qrg7-hfx7-95c5 Record: https://patchnext.com/advisories/cve-2022-31249 (revision 1, source checked 26 Oct 2026, 14:58 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/rancher/wrangler 1.0.1, 0.8.11, 0.8.5-security1, 0.7.4-security1. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/rancher/wrangler: affected >= 0.8.6, < 0.8.11; >= 1.0.0, <= 1.0.0; < 0.7.4-security1; >= 0.8.0, < 0.8.5-security1; fixed in 0.7.4-security1, 0.8.5-security1, 1.0.1, 0.8.11 ## Suggested inspection (read-only) - Go github.com/rancher/wrangler: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/rancher/wrangler. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-qrg7-hfx7-95c5 (GitHub-reviewed advisory GHSA-qrg7-hfx7-95c5 lists affected ranges: Go github.com/rancher/wrangler >=0.8.6 =1.0.0 =0 =0.8.0 <0.8.5-security1) Commands are suggestions: review each one before running it.
Loading voting…