Skip to content

← Actionable
High, CVSS 7.5amended

OpenZeppelin Contracts's GovernorVotesQuorumFraction updates to quorum may affect past defeated proposals

CVE-2022-31198GHSA-xrc4-737v-9q75

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@openzeppelin/contracts 4.7.2; @openzeppelin/contracts-upgradeable 4.7.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2022-31198: 0.79% estimated exploitation activity in the next 30 days; percentile 56.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact This issue concerns instances of Governor that use the module GovernorVotesQuorumFraction, a mechanism that determines quorum requirements as a percentage of the voting token's total supply. In affected instances, when a proposal is passed to lower the quorum requirement, past proposals may become executable if they had been defeated only due to lack of quorum, and the number of votes it received meets the new quorum requirement. Analysis of instances on chain found only one proposal that met this condition, and we are actively monitoring for new occurrences of this particular issue. Patches This issue has been patched in v4.7.2. Workarounds Avoid lowering quorum requirements if a past proposal was defeated for lack of quorum. References https://github.com/OpenZeppelin/openzeppelin-contracts/pull/3561 For more information If you have any questions or comments about this advisory, or need assistance deploying the fix, email us at security@openzeppelin.com.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-xrc4-737v-9q75

  2. Revision 1 · created ·

    Published from osv record GHSA-xrc4-737v-9q75

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-31198

Advisory: OpenZeppelin Contracts's GovernorVotesQuorumFraction updates to quorum may affect past defeated proposals
IDs: CVE-2022-31198, GHSA-xrc4-737v-9q75
Record: https://patchnext.com/advisories/cve-2022-31198 (revision 2, source checked 26 Oct 2026, 12:17 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @openzeppelin/contracts 4.7.2; @openzeppelin/contracts-upgradeable 4.7.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @openzeppelin/contracts: affected >= 4.3.0, < 4.7.2; fixed in 4.7.2
- npm @openzeppelin/contracts-upgradeable: affected >= 4.3.0, < 4.7.2; fixed in 4.7.2

## Suggested inspection (read-only)
- `npm ls @openzeppelin/contracts --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @openzeppelin/contracts-upgradeable --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @openzeppelin/contracts, @openzeppelin/contracts-upgradeable.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-xrc4-737v-9q75 (OSV record GHSA-xrc4-737v-9q75 lists affected ranges: npm @openzeppelin/contracts >=4.3.0 =4.3.0 <4.7.2 (fixed))
- Verified: https://github.com/advisories/GHSA-xrc4-737v-9q75 (GitHub-reviewed advisory GHSA-xrc4-737v-9q75 lists affected ranges: npm @openzeppelin/contracts >=4.3.0 =4.3.0 <4.7.2)

Commands are suggestions: review each one before running it.

Loading voting…