Skip to content

← Actionable
High, CVSS 7.1

PostgreSQL JDBC Driver SQL Injection in ResultSet.refreshRow() with malicious column names

CVE-2022-31197GHSA-r38f-c4h4-hqq2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.postgresql:postgresql 42.4.1, 42.3.7, 42.2.26), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.1 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2022-31197: 2.35% estimated exploitation activity in the next 30 days; percentile 83.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact What kind of vulnerability is it? Who is impacted? The PGJDBC implementation of the java.sql.ResultRow.refreshRow() method is not performing escaping of column names so a malicious column name that contains a statement terminator, e.g. ;, could lead to SQL injection. This could lead to executing additional SQL commands as the application's JDBC user. User applications that do not invoke the ResultSet.refreshRow() method are not impacted. User application that do invoke that method are impacted if the underlying database that they are querying via their JDBC application may be under the control of an attacker. The attack requires the attacker to trick the user into executing SQL against a table name who's column names would contain the malicious SQL and subsequently invoke the refreshRow() method on the ResultSet. For example: This example has a table with two columns. The name of the second column is crafted to contain a statement terminator followed by additional SQL.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-r38f-c4h4-hqq2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-31197

Advisory: PostgreSQL JDBC Driver SQL Injection in ResultSet.refreshRow() with malicious column names
IDs: CVE-2022-31197, GHSA-r38f-c4h4-hqq2
Record: https://patchnext.com/advisories/cve-2022-31197 (revision 1, source checked 26 Oct 2026, 16:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.postgresql:postgresql 42.4.1, 42.3.7, 42.2.26. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.postgresql:postgresql: affected < 42.2.26; >= 42.4.0, < 42.4.1; >= 42.3.0, < 42.3.7; fixed in 42.3.7, 42.4.1, 42.2.26

## Suggested inspection (read-only)
- Maven org.postgresql:postgresql: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.postgresql:postgresql.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-r38f-c4h4-hqq2 (GitHub-reviewed advisory GHSA-r38f-c4h4-hqq2 lists affected ranges: Maven org.postgresql:postgresql >=0 =42.4.0 =42.3.0 <42.3.7)

Commands are suggestions: review each one before running it.

Loading voting…