DSpace ItemImportService API Vulnerable to Path Traversal in Simple Archive Format Package Import
CVE-2022-31195GHSA-8rmh-55h4-93h5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.dspace:dspace-api 6.4, 5.11), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.dspace:dspace-api
- Affected
- >= 4.0, < 5.11>= 6.0, < 6.4
- Fixed in
- 5.11, 6.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8rmh-55h4-93h5 lists affected ranges: Maven org.dspace:dspace-api >=4.0 =6.0 <6.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.2 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-31195: 1.97% estimated exploitation activity in the next 30 days; percentile 80.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact ItemImportServiceImpl is vulnerable to a path traversal vulnerability. This means a malicious SAF (simple archive format) package could cause a file/directory to be created anywhere the Tomcat/DSpace user can write to on the server. However, this path traversal vulnerability is only possible by a user with special privileges (either Administrators or someone with command-line access to the server). This vulnerability impacts the XMLUI, JSPUI and command-line. This vulnerability does NOT impact 7.x. Patches DSpace 6.x: Fixed in 6.4 via commit: https://github.com/DSpace/DSpace/commit/7af52a0883a9dbc475cf3001f04ed11b24c8a4c0 6.x patch file: https://github.com/DSpace/DSpace/commit/7af52a0883a9dbc475cf3001f04ed11b24c8a4c0.patch (may be applied manually if an immediate upgrade to 6.4 or 7.x is not possible) DSpace 5.x: Fixed in 5.11 via commit: https://github.com/DSpace/DSpace/commit/56e76049185bbd87c994128a9d77735ad7af0199 5.x patch file:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-8rmh-55h4-93h5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-31195 Advisory: DSpace ItemImportService API Vulnerable to Path Traversal in Simple Archive Format Package Import IDs: CVE-2022-31195, GHSA-8rmh-55h4-93h5 Record: https://patchnext.com/advisories/cve-2022-31195 (revision 1, source checked 26 Oct 2026, 16:05 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.dspace:dspace-api 6.4, 5.11. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.dspace:dspace-api: affected >= 4.0, < 5.11; >= 6.0, < 6.4; fixed in 5.11, 6.4 ## Suggested inspection (read-only) - Maven org.dspace:dspace-api: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.dspace:dspace-api. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8rmh-55h4-93h5 (GitHub-reviewed advisory GHSA-8rmh-55h4-93h5 lists affected ranges: Maven org.dspace:dspace-api >=4.0 =6.0 <6.4) Commands are suggestions: review each one before running it.
Loading voting…