JSPUI's controlled vocabulary feature vulnerable to Open Redirect before v6.4 and v5.11
CVE-2022-31193GHSA-763j-q7wv-vf3m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.dspace:dspace-jspui 6.4, 5.11), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.dspace:dspace-jspui
- Affected
- >= 4.0, < 5.11>= 6.0, < 6.4
- Fixed in
- 5.11, 6.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-763j-q7wv-vf3m lists affected ranges: Maven org.dspace:dspace-jspui >=4.0 =6.0 <6.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
- EPSS
- CVE-2022-31193: 0.89% estimated exploitation activity in the next 30 days; percentile 59.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The JSPUI controlled vocabulary servlet is vulnerable to an open redirect attack, where an attacker can craft a malicious URL that looks like a legitimate DSpace/repository URL. When that URL is clicked by the target, it redirects them to a site of the attacker's choice. This vulnerability does NOT impact the XMLUI or 7.x. Patches DSpace 6.x: Fixed in 6.x via commit: https://github.com/DSpace/DSpace/commit/f7758457b7ec3489d525e39aa753cc70809d9ad9 6.x patch file: https://github.com/DSpace/DSpace/commit/f7758457b7ec3489d525e39aa753cc70809d9ad9.patch (may be applied manually if an immediate upgrade to 6.4 or above is not possible) DSpace 5.x: Fixed in 5.x via commit: https://github.com/DSpace/DSpace/commit/5f72424a478f59061dcc516b866dcc687bc3f9de 5.x patch file: https://github.com/DSpace/DSpace/commit/5f72424a478f59061dcc516b866dcc687bc3f9de.patch (may be applied manually if an immediate upgrade to 5.11 or 6,4 or above is not possible) Apply the patch to your DSpace If at all…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-763j-q7wv-vf3m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-31193 Advisory: JSPUI's controlled vocabulary feature vulnerable to Open Redirect before v6.4 and v5.11 IDs: CVE-2022-31193, GHSA-763j-q7wv-vf3m Record: https://patchnext.com/advisories/cve-2022-31193 (revision 1, source checked 26 Oct 2026, 16:01 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.dspace:dspace-jspui 6.4, 5.11. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.dspace:dspace-jspui: affected >= 4.0, < 5.11; >= 6.0, < 6.4; fixed in 5.11, 6.4 ## Suggested inspection (read-only) - Maven org.dspace:dspace-jspui: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.dspace:dspace-jspui. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-763j-q7wv-vf3m (GitHub-reviewed advisory GHSA-763j-q7wv-vf3m lists affected ranges: Maven org.dspace:dspace-jspui >=4.0 =6.0 <6.4) Commands are suggestions: review each one before running it.
Loading voting…