Skip to content

← Actionable
High, CVSS 7.1

JSPUI spellcheck and autocomplete tools vulnerable to Cross Site Scripting

CVE-2022-31191GHSA-c558-5gfm-p2r8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.dspace:dspace-jspui 6.4, 5.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
EPSS
  • CVE-2022-31191: 0.81% estimated exploitation activity in the next 30 days; percentile 56.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The JSPUI spellcheck "Did you mean" HTML escapes the data-spell attribute in the link, but not the actual displayed text. Similarly, the JSPUI autocomplete HTML does not properly escape text passed to it. Both are vulnerable to XSS. This vulnerability only impacts the JSPUI. This vulnerability does NOT impact the XMLUI or 7.x. Patches DSpace 6.x: Fixed in 6.4 via two commits: Fix for spellcheck: https://github.com/DSpace/DSpace/commit/ebb83a75234d3de9be129464013e998dc929b68d Fix for autocomplete: https://github.com/DSpace/DSpace/commit/35030a23e48b5946f5853332c797e1c4adea7bb7 6.x patch files available (may be applied manually if an immediate upgrade to 6.4 or above is not possible) Fix for spellcheck: https://github.com/DSpace/DSpace/commit/ebb83a75234d3de9be129464013e998dc929b68d.patch Fix for autocomplete: https://github.com/DSpace/DSpace/commit/35030a23e48b5946f5853332c797e1c4adea7bb7.patch DSpace 5.x: Fixed in 5.11 via two commits: Fix for spellcheck:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-c558-5gfm-p2r8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-31191

Advisory: JSPUI spellcheck and autocomplete tools vulnerable to Cross Site Scripting
IDs: CVE-2022-31191, GHSA-c558-5gfm-p2r8
Record: https://patchnext.com/advisories/cve-2022-31191 (revision 1, source checked 26 Oct 2026, 16:05 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.dspace:dspace-jspui 6.4, 5.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.dspace:dspace-jspui: affected >= 4.0, < 5.11; >= 6.0, < 6.4; fixed in 5.11, 6.4

## Suggested inspection (read-only)
- Maven org.dspace:dspace-jspui: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.dspace:dspace-jspui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-c558-5gfm-p2r8 (GitHub-reviewed advisory GHSA-c558-5gfm-p2r8 lists affected ranges: Maven org.dspace:dspace-jspui >=4.0 =6.0 <6.4)

Commands are suggestions: review each one before running it.

Loading voting…