Skip to content

← Actionable
Medium, CVSS 5.3

XMLUI's metadata of withdrawn Items is exposed to anonymous users

CVE-2022-31190GHSA-7w85-pp86-p4pq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.dspace:dspace-xmlui 6.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2022-31190: 0.92% estimated exploitation activity in the next 30 days; percentile 60.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Metadata on a withdrawn Item is exposed via the XMLUI "mets.xml" object, as long as you know the handle/URL of the withdrawn Item. This vulnerability only impacts the XMLUI. However, this vulnerability is very low severity as Item metadata does not tend to contain highly secure or sensitive information. This vulnerability does NOT impact the JSPUI or 7.x. Patches Because of the low severity of this security issue, it requires updating to 6.4 to resolve. No patch is available for 5.x or below. DSpace 6.x: Fixed in 6.4 via #2451 6.x patch file: https://github.com/DSpace/DSpace/commit/574e25496a40173653ae7d0a49a19ed8e3458606.patch (may be applied manually if an immediate upgrade to 6.4 or above is not possible) Apply the patch to your DSpace If at all possible, we recommend upgrading your DSpace site based on the upgrade instructions. However, if you are unable to do so, you can manually apply the above patches as follows: 1. Download the appropriate patch file to the machine…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-7w85-pp86-p4pq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-31190

Advisory: XMLUI's metadata of withdrawn Items is exposed to anonymous users
IDs: CVE-2022-31190, GHSA-7w85-pp86-p4pq
Record: https://patchnext.com/advisories/cve-2022-31190 (revision 1, source checked 26 Oct 2026, 16:11 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.dspace:dspace-xmlui 6.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.dspace:dspace-xmlui: affected >= 4.0, <= 6.3; fixed in 6.4

## Suggested inspection (read-only)
- Maven org.dspace:dspace-xmlui: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.dspace:dspace-xmlui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7w85-pp86-p4pq (GitHub-reviewed advisory GHSA-7w85-pp86-p4pq lists affected ranges: Maven org.dspace:dspace-xmlui >=4.0 <=6.3)

Commands are suggestions: review each one before running it.

Loading voting…