Skip to content

← Actionable
Medium, CVSS 5.3

JSPUI's "Internal System Error" page prints exceptions and stack traces without sanitization

CVE-2022-31189GHSA-c2j7-66m3-r4ff

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.dspace:dspace-jspui 6.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2022-31189: 0.72% estimated exploitation activity in the next 30 days; percentile 54.06 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact When an "Internal System Error" occurs in the JSPUI, then entire exception (including stack trace) is available. Information in this stacktrace may be useful to an attacker in launching a more sophisticated attack. This vulnerability only impacts the JSPUI. This vulnerability does NOT impact the XMLUI or 7.x. Patches DSpace 6.x: Fixed in 6.4 via commit: https://github.com/DSpace/DSpace/commit/afcc6c3389729b85d5c7b0230cbf9aaf7452f31a 6.x patch file: https://github.com/DSpace/DSpace/commit/afcc6c3389729b85d5c7b0230cbf9aaf7452f31a.patch (may be applied manually if an immediate upgrade to 6.4 or above is not possible) DSpace 5.x: The 6.x patch file can also be applied to an older 5.x installation. Alternatively, you can simply apply the workaround documented below. The detailed error information embedded in internal.jsp is not necessary for the JSPUI to function. Apply the patch to your DSpace If at all possible, we recommend upgrading your DSpace site based on the upgrade…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-c2j7-66m3-r4ff

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-31189

Advisory: JSPUI's "Internal System Error" page prints exceptions and stack traces without sanitization
IDs: CVE-2022-31189, GHSA-c2j7-66m3-r4ff
Record: https://patchnext.com/advisories/cve-2022-31189 (revision 1, source checked 26 Oct 2026, 16:01 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.dspace:dspace-jspui 6.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.dspace:dspace-jspui: affected >= 4.0, <= 6.3; fixed in 6.4

## Suggested inspection (read-only)
- Maven org.dspace:dspace-jspui: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.dspace:dspace-jspui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-c2j7-66m3-r4ff (GitHub-reviewed advisory GHSA-c2j7-66m3-r4ff lists affected ranges: Maven org.dspace:dspace-jspui >=4.0 <=6.3)

Commands are suggestions: review each one before running it.

Loading voting…