Skip to content

← Actionable
Critical, CVSS 9.8

fs2-io skips mTLS client verification

CVE-2022-31183GHSA-2cpx-6pqp-wf35

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (co.fs2:fs2-io_2.13 3.2.11; co.fs2:fs2-io_2.12 3.2.11; co.fs2:fs2-io_3 3.2.11; co.fs2:fs2-io_sjs1_2.13 3.2.11; co.fs2:fs2-io 3.2.11; 1 more package under Affected packages), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2022-31183: 0.83% estimated exploitation activity in the next 30 days; percentile 57.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact When establishing a server-mode TLSSocket using fs2-io on Node.js, the parameter requestCert = true is ignored, peer certificate verification is skipped, and the connection proceeds. The vulnerability is limited to: 1. fs2-io running on Node.js. The JVM TLS implementation is completely independent. 2. TLSSockets in server-mode. Client-mode TLSSockets are implemented via a different API. 3. mTLS as enabled via requestCert = true in TLSParameters. The default setting is false for server-mode TLSSockets. It was introduced with the initial Node.js implementation of fs2-io in v3.1.0. Patches A patch is released in v3.2.11. The requestCert = true parameter is respected and the peer certificate is verified. If verification fails, a SSLException is raised. Workarounds If using an unpatched version on Node.js, do not use a server-mode TLSSocket with requestCert = true to establish a mTLS connection. References - https://github.com/nodejs/node/issues/43994 -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-2cpx-6pqp-wf35

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-31183

Advisory: fs2-io skips mTLS client verification
IDs: CVE-2022-31183, GHSA-2cpx-6pqp-wf35
Record: https://patchnext.com/advisories/cve-2022-31183 (revision 1, source checked 26 Oct 2026, 16:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: co.fs2:fs2-io_2.13 3.2.11; co.fs2:fs2-io_2.12 3.2.11; co.fs2:fs2-io_3 3.2.11; co.fs2:fs2-io_sjs1_2.13 3.2.11; co.fs2:fs2-io 3.2.11; co.fs2:fs2-io_sjs1_3 3.2.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven co.fs2:fs2-io_2.13: affected >= 3.1.0, < 3.2.11; fixed in 3.2.11
- Maven co.fs2:fs2-io_2.12: affected >= 3.1.0, < 3.2.11; fixed in 3.2.11
- Maven co.fs2:fs2-io_3: affected >= 3.1.0, < 3.2.11; fixed in 3.2.11
- Maven co.fs2:fs2-io_sjs1_2.13: affected >= 3.1.0, < 3.2.11; fixed in 3.2.11
- Maven co.fs2:fs2-io: affected >= 3.1.0, < 3.2.11; fixed in 3.2.11
- Maven co.fs2:fs2-io_sjs1_3: affected >= 3.1.0, < 3.2.11; fixed in 3.2.11

## Suggested inspection (read-only)
- Maven co.fs2:fs2-io_2.13: check the installed version with your package manager.
- Maven co.fs2:fs2-io_2.12: check the installed version with your package manager.
- Maven co.fs2:fs2-io_3: check the installed version with your package manager.
- Maven co.fs2:fs2-io_sjs1_2.13: check the installed version with your package manager.
- Maven co.fs2:fs2-io: check the installed version with your package manager.
- Maven co.fs2:fs2-io_sjs1_3: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on co.fs2:fs2-io_2.13, co.fs2:fs2-io_2.12, co.fs2:fs2-io_3, co.fs2:fs2-io_sjs1_2.13, co.fs2:fs2-io, co.fs2:fs2-io_sjs1_3.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-2cpx-6pqp-wf35 (GitHub-reviewed advisory GHSA-2cpx-6pqp-wf35 lists affected ranges: Maven co.fs2:fs2-io >=3.1.0 =3.1.0 =3.1.0 =3.1.0 =3.1.0 =3.1.0 <3.2.11)

Commands are suggestions: review each one before running it.

Loading voting…