Skip to content

← Actionable
Critical, CVSS 9.8amended

Shescape vulnerable to insufficient escaping of whitespace

CVE-2022-31180GHSA-44vr-rwwj-p88h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (shescape 1.5.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm shescape

    Affected
    >= 1.4.0, < 1.5.8
    Fixed in
    1.5.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2022-31180: 1.99% estimated exploitation activity in the next 30 days; percentile 80.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact This only impacts users that use the escape or escapeAll functions with the interpolation option set to true. Example: The result is that if an attacker is able to include whitespace in their input they can: 1. Invoke shell-specific behaviour through shell-specific special characters inserted directly after whitespace. - Affected shells: Bash, Dash, Zsh, PowerShell 2. Invoke shell-specific behaviour through shell-specific special characters inserted or appearing after line terminating characters. - Affected shells: Bash 3. Invoke arbitrary commands by inserting a line feed character. - Affected Shells: Bash, Dash, Zsh, PowerShell 3. Invoke arbitrary commands by inserting a carriage return character. - Affected Shells: PowerShell Patches Behaviour number 1 has been patched in [v1.5.7] which you can upgrade to now. No further changes are required. Behaviour number 2, 3, and 4 have been patched in [v1.5.8] which you can upgrade to now. No further changes are required. Workarounds…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-44vr-rwwj-p88h

  2. Revision 1 · created ·

    Published from osv record GHSA-44vr-rwwj-p88h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-31180

Advisory: Shescape vulnerable to insufficient escaping of whitespace
IDs: CVE-2022-31180, GHSA-44vr-rwwj-p88h
Record: https://patchnext.com/advisories/cve-2022-31180 (revision 2, source checked 26 Oct 2026, 12:17 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: shescape 1.5.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm shescape: affected >= 1.4.0, < 1.5.8; fixed in 1.5.8

## Suggested inspection (read-only)
- `npm ls shescape --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on shescape.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-44vr-rwwj-p88h (OSV record GHSA-44vr-rwwj-p88h lists affected ranges: npm shescape >=1.4.0 <1.5.8 (fixed))
- Verified: https://github.com/advisories/GHSA-44vr-rwwj-p88h (GitHub-reviewed advisory GHSA-44vr-rwwj-p88h lists affected ranges: npm shescape >=1.4.0 <1.5.8)

Commands are suggestions: review each one before running it.

Loading voting…