Skip to content

← Actionable
High, CVSS 8.1amended

Shescape prior to 1.5.8 vulnerable to insufficient escaping of line feeds for CMD

CVE-2022-31179GHSA-jjc5-fp7p-6f8w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (shescape 1.5.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm shescape

    Affected
    < 1.5.8
    Fixed in
    1.5.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:H
EPSS
  • CVE-2022-31179: 1.42% estimated exploitation activity in the next 30 days; percentile 72.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact This impacts users that use Shescape (any API function) to escape arguments for cmd.exe on Windows. An attacker can omit all arguments following their input by including a line feed character ('\n') in the payload. Example: Note: execSync is just illustrative here, all of exec, execFile, execFileSync, fork, spawn, and spawnSync can be attacked using a line feed character if CMD is the shell being used. Patches This bug has been patched in [v1.5.8] which you can upgrade to now. No further changes are required. Workarounds Alternatively, line feed characters ('\n') can be stripped out manually or the user input can be made the last argument (this only limits the impact). References - https://github.com/ericcornelissen/shescape/pull/332 - https://github.com/ericcornelissen/shescape/releases/tag/v1.5.8 For more information If you have any questions or comments about this advisory: - Comment on https://github.com/ericcornelissen/shescape/pull/332 - Open an issue at…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-jjc5-fp7p-6f8w

  2. Revision 1 · created ·

    Published from osv record GHSA-jjc5-fp7p-6f8w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-31179

Advisory: Shescape prior to 1.5.8 vulnerable to insufficient escaping of line feeds for CMD
IDs: CVE-2022-31179, GHSA-jjc5-fp7p-6f8w
Record: https://patchnext.com/advisories/cve-2022-31179 (revision 2, source checked 26 Oct 2026, 12:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: shescape 1.5.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm shescape: affected < 1.5.8; fixed in 1.5.8

## Suggested inspection (read-only)
- `npm ls shescape --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on shescape.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-jjc5-fp7p-6f8w (OSV record GHSA-jjc5-fp7p-6f8w lists affected ranges: npm shescape >=0 <1.5.8 (fixed))
- Verified: https://github.com/advisories/GHSA-jjc5-fp7p-6f8w (GitHub-reviewed advisory GHSA-jjc5-fp7p-6f8w lists affected ranges: npm shescape >=0 <1.5.8)

Commands are suggestions: review each one before running it.

Loading voting…