Skip to content

← Actionable
Low, CVSS 2.7amended

Flask-AppBuilder before v4.1.3 allows inference of sensitive information through query strings

CVE-2022-31177GHSA-32ff-4g79-vgfc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (flask-appbuilder 4.1.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
2.7 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2022-31177: 0.77% estimated exploitation activity in the next 30 days; percentile 55.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An authenticated Admin user could craft HTTP requests to filter users by their salted and hashed passwords strings. These filters could be made by using partial hashed password strings. The response would not include the hashed passwords, but an attacker could infer partial password hashes and their respective users. Only when using AUTHDB database authentication option. Patches Fixed on 4.1.3 For more information If you have any questions or comments about this advisory: Open an issue in example link to repo Email us at example email address

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-32ff-4g79-vgfc

  2. Revision 1 · created ·

    Published from osv record GHSA-32ff-4g79-vgfc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-31177

Advisory: Flask-AppBuilder before v4.1.3 allows inference of sensitive information through query strings
IDs: CVE-2022-31177, GHSA-32ff-4g79-vgfc
Record: https://patchnext.com/advisories/cve-2022-31177 (revision 2, source checked 26 Oct 2026, 13:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: flask-appbuilder 4.1.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI flask-appbuilder: affected < 4.1.3; fixed in 4.1.3

## Suggested inspection (read-only)
- `python -m pip show flask-appbuilder`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on flask-appbuilder.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-32ff-4g79-vgfc (OSV record GHSA-32ff-4g79-vgfc lists affected ranges: PyPI flask-appbuilder >=0 <4.1.3 (fixed))
- Verified: https://github.com/advisories/GHSA-32ff-4g79-vgfc (GitHub-reviewed advisory GHSA-32ff-4g79-vgfc lists affected ranges: PyPI flask-appbuilder >=0 <4.1.3)

Commands are suggestions: review each one before running it.

Loading voting…