Skip to content

← Actionable
High, CVSS 7.5amended

OpenZeppelin Contracts's ERC165Checker may revert instead of returning false

CVE-2022-31170GHSA-qh9x-gcfh-pcrw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@openzeppelin/contracts 4.7.1; @openzeppelin/contracts-upgradeable 4.7.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2022-31170: 0.79% estimated exploitation activity in the next 30 days; percentile 56.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact ERC165Checker.supportsInterface is designed to always successfully return a boolean, and under no circumstance revert. However, an incorrect assumption about Solidity 0.8's abi.decode allows some cases to revert, given a target contract that doesn't implement EIP-165 as expected, specifically if it returns a value other than 0 or 1. The contracts that may be affected are those that use ERC165Checker to check for support for an interface and then handle the lack of support in a way other than reverting. Patches The issue was patched in 4.7.1. References https://github.com/OpenZeppelin/openzeppelin-contracts/pull/3552 For more information If you have any questions or comments about this advisory, or need assistance deploying the fix, email us at security@openzeppelin.com.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-qh9x-gcfh-pcrw

  2. Revision 1 · created ·

    Published from osv record GHSA-qh9x-gcfh-pcrw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-31170

Advisory: OpenZeppelin Contracts's ERC165Checker may revert instead of returning false
IDs: CVE-2022-31170, GHSA-qh9x-gcfh-pcrw
Record: https://patchnext.com/advisories/cve-2022-31170 (revision 2, source checked 26 Oct 2026, 12:17 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @openzeppelin/contracts 4.7.1; @openzeppelin/contracts-upgradeable 4.7.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @openzeppelin/contracts: affected >= 4.0.0, < 4.7.1; fixed in 4.7.1
- npm @openzeppelin/contracts-upgradeable: affected >= 4.0.0, < 4.7.1; fixed in 4.7.1

## Suggested inspection (read-only)
- `npm ls @openzeppelin/contracts --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @openzeppelin/contracts-upgradeable --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @openzeppelin/contracts, @openzeppelin/contracts-upgradeable.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-qh9x-gcfh-pcrw (OSV record GHSA-qh9x-gcfh-pcrw lists affected ranges: npm @openzeppelin/contracts >=4.0.0 =4.0.0 <4.7.1 (fixed))
- Verified: https://github.com/advisories/GHSA-qh9x-gcfh-pcrw (GitHub-reviewed advisory GHSA-qh9x-gcfh-pcrw lists affected ranges: npm @openzeppelin/contracts >=4.0.0 =4.0.0 <4.7.1)

Commands are suggestions: review each one before running it.

Loading voting…