Skip to content

← Actionable
High, CVSS 7.1

XWiki Platform Security Parent POM vulnerable to overwriting of security rules of a page with a final page having the same reference

CVE-2022-31167GHSA-gg53-wf5x-r3r6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.platform:xwiki-platform-security 13.10.1, 13.4.6, 12.10.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N
EPSS
  • CVE-2022-31167: 0.84% estimated exploitation activity in the next 30 days; percentile 57.90 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A bug in the security cache is storing rules associated to document Page1.Page2 and space Page1.Page2 in the same cache entry. That means that it's possible to overwrite the rights of a space or a document by creating the page of the space with the same name and checking the right of the new one first so that they end up in the security cache and are used for the other too. Patches The problem has been patched in XWiki 12.10.11, 13.10.1, 13.4.6. Workarounds No workaround other than patching. References https://jira.xwiki.org/browse/XWIKI-14075 https://jira.xwiki.org/browse/XWIKI-18983 For more information If you have any questions or comments about this advisory: Open an issue in Jira XWiki.org Email us at Security Mailing List

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-gg53-wf5x-r3r6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-31167

Advisory: XWiki Platform Security Parent POM vulnerable to overwriting of security rules of a page with a final page having the same reference
IDs: CVE-2022-31167, GHSA-gg53-wf5x-r3r6
Record: https://patchnext.com/advisories/cve-2022-31167 (revision 1, source checked 26 Oct 2026, 16:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.xwiki.platform:xwiki-platform-security 13.10.1, 13.4.6, 12.10.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.xwiki.platform:xwiki-platform-security: affected >= 5.0, < 12.10.11; >= 13.0, < 13.4.6; >= 13.10, < 13.10.1; fixed in 13.4.6, 13.10.1, 12.10.11

## Suggested inspection (read-only)
- Maven org.xwiki.platform:xwiki-platform-security: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.xwiki.platform:xwiki-platform-security.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gg53-wf5x-r3r6 (GitHub-reviewed advisory GHSA-gg53-wf5x-r3r6 lists affected ranges: Maven org.xwiki.platform:xwiki-platform-security >=5.0 =13.0 =13.10 <13.10.1)

Commands are suggestions: review each one before running it.

Loading voting…