TZInfo relative path traversal vulnerability allows loading of arbitrary files
CVE-2022-31163GHSA-5cm2-9h8c-rvfx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (tzinfo 1.2.10, 0.3.61), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems tzinfo
- Affected
- < 0.3.61>= 1.0.0, < 1.2.10
- Fixed in
- 1.2.10, 0.3.61
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5cm2-9h8c-rvfx lists affected ranges: RubyGems tzinfo >=0 =1.0.0 <1.2.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-31163: 2.45% estimated exploitation activity in the next 30 days; percentile 84.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Affected versions - 0.3.60 and earlier. - 1.0.0 to 1.2.9 when used with the Ruby data source (tzinfo-data). Vulnerability With the Ruby data source (the tzinfo-data gem for tzinfo version 1.0.0 and later and built-in to earlier versions), time zones are defined in Ruby files. There is one file per time zone. Time zone files are loaded with require on demand. In the affected versions, TZInfo::Timezone.get fails to validate time zone identifiers correctly, allowing a new line character within the identifier. With Ruby version 1.9.3 and later, TZInfo::Timezone.get can be made to load unintended files with require, executing them within the Ruby process. For example, with version 1.2.9, you can run the following to load a file with path /tmp/payload.rb: The exact number of parent directory traversals needed will vary depending on the location of the tzinfo-data gem. TZInfo versions 1.2.6 to 1.2.9 can be made to load files from outside of the Ruby load path. Versions up to and…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5cm2-9h8c-rvfx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-31163 Advisory: TZInfo relative path traversal vulnerability allows loading of arbitrary files IDs: CVE-2022-31163, GHSA-5cm2-9h8c-rvfx Record: https://patchnext.com/advisories/cve-2022-31163 (revision 1, source checked 26 Oct 2026, 15:44 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: tzinfo 1.2.10, 0.3.61. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems tzinfo: affected < 0.3.61; >= 1.0.0, < 1.2.10; fixed in 1.2.10, 0.3.61 ## Suggested inspection (read-only) - RubyGems tzinfo: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on tzinfo. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5cm2-9h8c-rvfx (GitHub-reviewed advisory GHSA-5cm2-9h8c-rvfx lists affected ranges: RubyGems tzinfo >=0 =1.0.0 <1.2.10) Commands are suggestions: review each one before running it.
Loading voting…