Skip to content

← Actionable
Medium, CVSS 6.1amended

jQuery UI vulnerable to XSS when refreshing a checkboxradio with an HTML-like initial text label

CVE-2022-31160GHSA-h6gj-6jjq-h8g9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.webjars.npm:jquery-ui 1.13.2; jquery.ui.combined 1.13.2; jquery-ui 1.13.2; jquery-ui-rails 8.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2022-31160: 2.69% estimated exploitation activity in the next 30 days; percentile 85.90 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Initializing a checkboxradio widget on an input enclosed within a label makes that parent label contents considered as the input label. If you call .checkboxradio( "refresh" ) on such a widget and the initial HTML contained encoded HTML entities, they will erroneously get decoded. This can lead to potentially executing JavaScript code. For example, starting with the following initial secure HTML: and calling: will turn the initial HTML into: and the alert will get executed. Patches The bug has been patched in jQuery UI 1.13.2. Workarounds To remediate the issue, if you can change the initial HTML, you can wrap all the non-input contents of the label in a span: References https://blog.jqueryui.com/2022/07/jquery-ui-1-13-2-released/ For more information If you have any questions or comments about this advisory, search for a relevant issue in the jQuery UI repo. If you don't find an answer, open a new issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-h6gj-6jjq-h8g9

  2. Revision 1 · created ·

    Published from osv record GHSA-h6gj-6jjq-h8g9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-31160

Advisory: jQuery UI vulnerable to XSS when refreshing a checkboxradio with an HTML-like initial text label
IDs: CVE-2022-31160, GHSA-h6gj-6jjq-h8g9
Record: https://patchnext.com/advisories/cve-2022-31160 (revision 2, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.webjars.npm:jquery-ui 1.13.2; jquery.ui.combined 1.13.2; jquery-ui 1.13.2; jquery-ui-rails 8.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.webjars.npm:jquery-ui: affected < 1.13.2; fixed in 1.13.2
- NuGet jquery.ui.combined: affected < 1.13.2; fixed in 1.13.2
- npm jquery-ui: affected < 1.13.2; fixed in 1.13.2
- RubyGems jquery-ui-rails: affected < 8.0.0; fixed in 8.0.0

## Suggested inspection (read-only)
- Maven org.webjars.npm:jquery-ui: check the installed version with your package manager.
- NuGet jquery.ui.combined: check the installed version with your package manager.
- `npm ls jquery-ui --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- RubyGems jquery-ui-rails: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.webjars.npm:jquery-ui, jquery.ui.combined, jquery-ui, jquery-ui-rails.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-h6gj-6jjq-h8g9 (OSV record GHSA-h6gj-6jjq-h8g9 lists affected ranges: npm jquery-ui >=0 =0 =0 =0 <1.13.2 (fixed))
- Verified: https://github.com/advisories/GHSA-h6gj-6jjq-h8g9 (GitHub-reviewed advisory GHSA-h6gj-6jjq-h8g9 lists affected ranges: npm jquery-ui >=0 =0 =0 =0 <8.0.0)

Commands are suggestions: review each one before running it.

Loading voting…