undici before v5.8.0 vulnerable to CRLF injection in request headers
CVE-2022-31150GHSA-3cvr-822r-rqcc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (undici 5.8.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm undici
- Affected
- < 5.8.0
- Fixed in
- 5.8.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-3cvr-822r-rqcc lists affected ranges: npm undici >=0 <5.8.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3cvr-822r-rqcc lists affected ranges: npm undici >=0 <5.8.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- EPSS
- CVE-2022-31150: 1.52% estimated exploitation activity in the next 30 days; percentile 74.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact It is possible to inject CRLF sequences into request headers in Undici. The same applies to path and method Patches Update to v5.8.0 Workarounds Sanitize all HTTP headers from untrusted sources to eliminate \r\n. References https://hackerone.com/reports/409943 https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12116 For more information If you have any questions or comments about this advisory: Open an issue in undici repository To make a report, follow the SECURITY document
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-3cvr-822r-rqcc
- Revision 1 · created ·
Published from osv record GHSA-3cvr-822r-rqcc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-31150 Advisory: undici before v5.8.0 vulnerable to CRLF injection in request headers IDs: CVE-2022-31150, GHSA-3cvr-822r-rqcc Record: https://patchnext.com/advisories/cve-2022-31150 (revision 2, source checked 26 Oct 2026, 12:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: undici 5.8.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm undici: affected < 5.8.0; fixed in 5.8.0 ## Suggested inspection (read-only) - `npm ls undici --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on undici. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-3cvr-822r-rqcc (OSV record GHSA-3cvr-822r-rqcc lists affected ranges: npm undici >=0 <5.8.0 (fixed)) - Verified: https://github.com/advisories/GHSA-3cvr-822r-rqcc (GitHub-reviewed advisory GHSA-3cvr-822r-rqcc lists affected ranges: npm undici >=0 <5.8.0) Commands are suggestions: review each one before running it.
Loading voting…