Valinor error messages leading to potential data exfiltration before v0.12.0
CVE-2022-31140GHSA-5pgm-3j3g-2rc7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (cuyz/valinor 0.12.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist cuyz/valinor
- Affected
- < 0.12.0
- Fixed in
- 0.12.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5pgm-3j3g-2rc7 lists affected ranges: Packagist cuyz/valinor >=0 <0.12.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2022-31140: 1.49% estimated exploitation activity in the next 30 days; percentile 74.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Now, this is quite innocent: it produces following output: The problem is that nowhere I told valinor that it could use Throwable#getMessage(). This is a problem with cases where you get: an SQL exception showing an SQL snippet a DB connection exception showing DB ip address/username/password a timeout detail / out of memory detail (exploring DDoS possibilities) This allows for potential data exfiltration, DDoS, enumeration attacks, etc.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5pgm-3j3g-2rc7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-31140 Advisory: Valinor error messages leading to potential data exfiltration before v0.12.0 IDs: CVE-2022-31140, GHSA-5pgm-3j3g-2rc7 Record: https://patchnext.com/advisories/cve-2022-31140 (revision 1, source checked 26 Oct 2026, 14:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: cuyz/valinor 0.12.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist cuyz/valinor: affected < 0.12.0; fixed in 0.12.0 ## Suggested inspection (read-only) - Packagist cuyz/valinor: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on cuyz/valinor. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5pgm-3j3g-2rc7 (GitHub-reviewed advisory GHSA-5pgm-3j3g-2rc7 lists affected ranges: Packagist cuyz/valinor >=0 <0.12.0) Commands are suggestions: review each one before running it.
Loading voting…