Improper handling of email input
CVE-2022-31127GHSA-pgjx-7f9g-9463
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (next-auth 4.9.0, 3.29.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm next-auth
- Affected
- < 3.29.8>= 4.0.0, < 4.9.0
- Fixed in
- 4.9.0, 3.29.8
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pgjx-7f9g-9463 lists affected ranges: npm next-auth >=0 =4.0.0 <4.9.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pgjx-7f9g-9463 lists affected ranges: npm next-auth >=0 =4.0.0 <4.9.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
- EPSS
- CVE-2022-31127: 1.13% estimated exploitation activity in the next 30 days; percentile 66.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An attacker can pass a compromised input to the e-mail signin endpoint that contains some malicious HTML, tricking the e-mail server to send it to the user, so they can perform a phishing attack. Eg.: balazs@email.com, <a href="http://attacker.com"Before signing in, claim your money!</a. This was previously sent to balazs@email.com, and the content of the email containing a link to the attacker's site was rendered in the HTML. This has been remedied in the following releases, by simply not rendering that e-mail in the HTML, since it should be obvious to the receiver what e-mail they used: next-auth v3 users before version 3.29.8 are impacted. (We recommend upgrading to v4, as v3 is considered unmaintained. See our migration guide) next-auth v4 users before version 4.8.0 are impacted. Patches We've released patches for this vulnerability in: - v3 - 3.29.8 - v4 - 4.9.0 You can do: (This will update to the latest v4 version, but you can change latest to 3 if you want to stay on…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-pgjx-7f9g-9463
- Revision 1 · created ·
Published from osv record GHSA-pgjx-7f9g-9463
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-31127 Advisory: Improper handling of email input IDs: CVE-2022-31127, GHSA-pgjx-7f9g-9463 Record: https://patchnext.com/advisories/cve-2022-31127 (revision 2, source checked 26 Oct 2026, 12:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: next-auth 4.9.0, 3.29.8. A vendor fix does not mean a deployment is fixed. ## Affected components - npm next-auth: affected < 3.29.8; >= 4.0.0, < 4.9.0; fixed in 4.9.0, 3.29.8 ## Suggested inspection (read-only) - `npm ls next-auth --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on next-auth. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-pgjx-7f9g-9463 (OSV record GHSA-pgjx-7f9g-9463 lists affected ranges: npm next-auth >=0 =4.0.0 <4.9.0 (fixed)) - Verified: https://github.com/advisories/GHSA-pgjx-7f9g-9463 (GitHub-reviewed advisory GHSA-pgjx-7f9g-9463 lists affected ranges: npm next-auth >=0 =4.0.0 <4.9.0) Commands are suggestions: review each one before running it.
Loading voting…