Skip to content

← Actionable
High, CVSS 7.5amended

Incorrect handling of invalid surrogate pair characters

CVE-2022-31116GHSA-wpqr-jcpx-745r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ujson 5.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI ujson

    Affected
    < 5.4.0
    Fixed in
    5.4.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2022-31116: 2.54% estimated exploitation activity in the next 30 days; percentile 85.03 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact What kind of vulnerability is it? Who is impacted? Anyone parsing JSON from an untrusted source is vulnerable. JSON strings that contain escaped surrogate characters not part of a proper surrogate pair were decoded incorrectly. Besides corrupting strings, this allowed for potential key confusion and value overwriting in dictionaries. Examples: Patches Has the problem been patched? What versions should users upgrade to? Users should upgrade to UltraJSON 5.4.0. From version 5.4.0, UltraJSON decodes lone surrogates in the same way as the standard library's json module does, preserving them in the parsed output: Workarounds Is there a way for users to fix or remediate the vulnerability without upgrading? Short of switching to an entirely different JSON library, there are no safe alternatives to upgrading. For more information If you have any questions or comments about this advisory: Open an issue in UltraJSON

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-wpqr-jcpx-745r

  2. Revision 1 · created ·

    Published from osv record GHSA-wpqr-jcpx-745r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-31116

Advisory: Incorrect handling of invalid surrogate pair characters
IDs: CVE-2022-31116, GHSA-wpqr-jcpx-745r
Record: https://patchnext.com/advisories/cve-2022-31116 (revision 2, source checked 26 Oct 2026, 13:08 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ujson 5.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI ujson: affected < 5.4.0; fixed in 5.4.0

## Suggested inspection (read-only)
- `python -m pip show ujson`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ujson.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-wpqr-jcpx-745r (OSV record GHSA-wpqr-jcpx-745r lists affected ranges: PyPI ujson >=0 <5.4.0 (fixed))
- Verified: https://github.com/advisories/GHSA-wpqr-jcpx-745r (GitHub-reviewed advisory GHSA-wpqr-jcpx-745r lists affected ranges: PyPI ujson >=0 <5.4.0)

Commands are suggestions: review each one before running it.

Loading voting…