Skip to content

← Actionable
Medium, CVSS 4.1amended

Possible inject arbitrary CSS into the generated graph affecting the container HTML

CVE-2022-31108GHSA-x3vm-38hw-55wf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mermaid 9.1.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm mermaid

    Affected
    >= 8.0.0, < 9.1.2
    Fixed in
    9.1.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:N/A:N
EPSS
  • CVE-2022-31108: 0.91% estimated exploitation activity in the next 30 days; percentile 60.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

An attacker is able to inject arbitrary CSS into the generated graph allowing them to change the styling of elements outside of the generated graph, and potentially exfiltrate sensitive information by using specially crafted CSS selectors. The following example shows how an attacker can exfiltrate the contents of an input field by bruteforcing the value attribute one character at a time. Whenever there is an actual match, an http request will be made by the browser in order to "load" a background image that will let an attacker know what's the value of the character. Patches Has the problem been patched? What versions should users upgrade to? Workarounds Is there a way for users to fix or remediate the vulnerability without upgrading? References Are there any links users can visit to find out more? For more information If you have any questions or comments about this advisory: Open an issue in example link to repo Email us at example email address Product mermaid.js Tested Version…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-x3vm-38hw-55wf

  2. Revision 1 · created ·

    Published from osv record GHSA-x3vm-38hw-55wf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-31108

Advisory: Possible inject arbitrary `CSS` into the generated graph affecting the container HTML
IDs: CVE-2022-31108, GHSA-x3vm-38hw-55wf
Record: https://patchnext.com/advisories/cve-2022-31108 (revision 2, source checked 26 Oct 2026, 12:22 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mermaid 9.1.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm mermaid: affected >= 8.0.0, < 9.1.2; fixed in 9.1.2

## Suggested inspection (read-only)
- `npm ls mermaid --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mermaid.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-x3vm-38hw-55wf (OSV record GHSA-x3vm-38hw-55wf lists affected ranges: npm mermaid >=8.0.0 <9.1.2 (fixed))
- Verified: https://github.com/advisories/GHSA-x3vm-38hw-55wf (GitHub-reviewed advisory GHSA-x3vm-38hw-55wf lists affected ranges: npm mermaid >=8.0.0 <9.1.2)

Commands are suggestions: review each one before running it.

Loading voting…