Improper handling of CSS at-rules in lettersanitizer
CVE-2022-31103GHSA-7r3r-gq8p-v9jj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (lettersanitizer 1.0.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm lettersanitizer
- Affected
- < 1.0.2
- Fixed in
- 1.0.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7r3r-gq8p-v9jj lists affected ranges: npm lettersanitizer >=0 <1.0.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7r3r-gq8p-v9jj lists affected ranges: npm lettersanitizer >=0 <1.0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2022-31103: 1.53% estimated exploitation activity in the next 30 days; percentile 74.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact All versions of lettersanitizer below 1.0.2 are affected by a denial of service issue when processing a CSS at-rule @keyframes. This package is depended on by react-letter, therefore everyone using react-letter is also at risk. Patches The problem has been patched in version 1.0.2. Workarounds There is no workaround besides upgrading. References The issue was originally reported in the react-letter repository: https://github.com/mat-sz/react-letter/issues/17 For more information If you have any questions or comments about this advisory: Open an issue in lettersanitizer Email me at contact@matsz.dev
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-7r3r-gq8p-v9jj
- Revision 1 · created ·
Published from osv record GHSA-7r3r-gq8p-v9jj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-31103 Advisory: Improper handling of CSS at-rules in lettersanitizer IDs: CVE-2022-31103, GHSA-7r3r-gq8p-v9jj Record: https://patchnext.com/advisories/cve-2022-31103 (revision 2, source checked 26 Oct 2026, 12:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: lettersanitizer 1.0.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm lettersanitizer: affected < 1.0.2; fixed in 1.0.2 ## Suggested inspection (read-only) - `npm ls lettersanitizer --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on lettersanitizer. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7r3r-gq8p-v9jj (OSV record GHSA-7r3r-gq8p-v9jj lists affected ranges: npm lettersanitizer >=0 <1.0.2 (fixed)) - Verified: https://github.com/advisories/GHSA-7r3r-gq8p-v9jj (GitHub-reviewed advisory GHSA-7r3r-gq8p-v9jj lists affected ranges: npm lettersanitizer >=0 <1.0.2) Commands are suggestions: review each one before running it.
Loading voting…