Skip to content

← Actionable
Low, CVSS 2.6

Argo CD SSO users vulnerable to Cross-site Scripting

CVE-2022-31102GHSA-pmjg-52h9-72qv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/argoproj/argo-cd 2.4.5, 2.3.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
2.6 · CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:N/I:L/A:N
EPSS
  • CVE-2022-31102: 0.63% estimated exploitation activity in the next 30 days; percentile 50.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact All versions of Argo CD starting with 2.3.0 are vulnerable to a cross-site scripting (XSS) bug which could allow an attacker to inject arbitrary JavaScript in the /auth/callback page in a victim's browser. This vulnerability only affects Argo CD instances which have SSO enabled. The exploit also assumes the attacker has 1) access to the API server's encryption key, 2) a method to add a cookie to the victim's browser, and 3) the ability to convince the victim to visit a malicious /auth/callback link. The vulnerability is classified as low severity, because access to the API server's encryption key already grants a high level of access. Exploiting the XSS would allow the attacker to impersonate the victim, but would not grant any privileges which the attacker could not otherwise gain using the encryption key. Patches A patch for this vulnerability has been released in the following Argo CD versions: v2.4.5 v2.3.6 Workarounds There is no workaround besides upgrading. Credits…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-pmjg-52h9-72qv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-31102

Advisory: Argo CD SSO users vulnerable to Cross-site Scripting
IDs: CVE-2022-31102, GHSA-pmjg-52h9-72qv
Record: https://patchnext.com/advisories/cve-2022-31102 (revision 1, source checked 26 Oct 2026, 14:58 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/argoproj/argo-cd 2.4.5, 2.3.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/argoproj/argo-cd: affected >= 2.3.0, < 2.3.6; >= 2.4.0, < 2.4.5; fixed in 2.4.5, 2.3.6

## Suggested inspection (read-only)
- Go github.com/argoproj/argo-cd: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/argoproj/argo-cd.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-pmjg-52h9-72qv (GitHub-reviewed advisory GHSA-pmjg-52h9-72qv lists affected ranges: Go github.com/argoproj/argo-cd >=2.3.0 =2.4.0 <2.4.5)

Commands are suggestions: review each one before running it.

Loading voting…