Skip to content

← Actionable
Medium, CVSS 6.5

Uncontrolled Recursion in rulex

CVE-2022-31099GHSA-v78m-2q7v-fjqp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (rulex 0.4.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io rulex

    Affected
    < 0.4.3
    Fixed in
    0.4.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2022-31099: 0.97% estimated exploitation activity in the next 30 days; percentile 61.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact When parsing untrusted rulex expressions, the stack may overflow, possibly enabling a Denial of Service attack. This happens when parsing an expression with several hundred levels of nesting, causing the process to abort immediately. This is a security concern for you, if - your service parses untrusted rulex expressions (expressions provided by an untrusted user), and - your service becomes unavailable when the process running rulex aborts due to a stack overflow. Patches The crash is fixed in version 0.4.3. Affected users are advised to update to this version. Workarounds None. For more information If you have any questions or comments about this advisory: Open an issue in rulex Email me at ludwig.stecher@gmx.de Credits Credit for finding these bugs goes to - evanrichter - ForAllSecure Mayhem - cargo fuzz and afl.rs

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-v78m-2q7v-fjqp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-31099

Advisory: Uncontrolled Recursion in rulex
IDs: CVE-2022-31099, GHSA-v78m-2q7v-fjqp
Record: https://patchnext.com/advisories/cve-2022-31099 (revision 1, source checked 26 Oct 2026, 15:33 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: rulex 0.4.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io rulex: affected < 0.4.3; fixed in 0.4.3

## Suggested inspection (read-only)
- crates.io rulex: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on rulex.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-v78m-2q7v-fjqp (GitHub-reviewed advisory GHSA-v78m-2q7v-fjqp lists affected ranges: crates.io rulex >=0 <0.4.3)

Commands are suggestions: review each one before running it.

Loading voting…