Skip to content

← Actionable
High, CVSS 7.7

Change in port should be considered a change in origin

CVE-2022-31091GHSA-q559-8m2m-g699

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (guzzlehttp/guzzle 7.4.5, 6.5.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
EPSS
  • CVE-2022-31091: 1.57% estimated exploitation activity in the next 30 days; percentile 75.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Authorization and Cookie headers on requests are sensitive information. On making a request which responds with a redirect to a URI with a different port, if we choose to follow it, we should remove the Authorization and Cookie headers from the request, before containing. Previously, we would only consider a change in host or scheme downgrade. Now, we consider any change in host, port or scheme to be a change in origin. Patches Affected Guzzle 7 users should upgrade to Guzzle 7.4.5 as soon as possible. Affected users using any earlier series of Guzzle should upgrade to Guzzle 6.5.8 or 7.4.5. Workarounds An alternative approach would be to use your own redirect middleware, rather than ours, if you are unable to upgrade. If you do not require or expect redirects to be followed, one should simply disable redirects all together. References RFC9110 Section 15.4 CVE-2022-27776 For more information If you have any questions or comments about this advisory, please get in touch with us…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-q559-8m2m-g699

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-31091

Advisory: Change in port should be considered a change in origin
IDs: CVE-2022-31091, GHSA-q559-8m2m-g699
Record: https://patchnext.com/advisories/cve-2022-31091 (revision 1, source checked 26 Oct 2026, 14:05 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: guzzlehttp/guzzle 7.4.5, 6.5.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist guzzlehttp/guzzle: affected < 6.5.8; >= 7.0.0, < 7.4.5; fixed in 7.4.5, 6.5.8

## Suggested inspection (read-only)
- Packagist guzzlehttp/guzzle: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on guzzlehttp/guzzle.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-q559-8m2m-g699 (GitHub-reviewed advisory GHSA-q559-8m2m-g699 lists affected ranges: Packagist guzzlehttp/guzzle >=0 =7.0.0 <7.4.5)

Commands are suggestions: review each one before running it.

Loading voting…