CURLOPT_HTTPAUTH option not cleared on change of origin
CVE-2022-31090GHSA-25mq-v84q-4j7r
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (guzzlehttp/guzzle 7.4.5, 6.5.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist guzzlehttp/guzzle
- Affected
- < 6.5.8>= 7.0.0, < 7.4.5
- Fixed in
- 7.4.5, 6.5.8
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-25mq-v84q-4j7r lists affected ranges: Packagist guzzlehttp/guzzle >=0 =7.0.0 <7.4.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
- EPSS
- CVE-2022-31090: 1.92% estimated exploitation activity in the next 30 days; percentile 79.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Authorization headers on requests are sensitive information. When using our Curl handler, it is possible to use the CURLOPTHTTPAUTH option to specify an Authorization header. On making a request which responds with a redirect to a URI with a different origin, if we choose to follow it, we should remove the CURLOPTHTTPAUTH and CURLOPTUSERPWD options before continuing, stopping curl from appending the Authorization header to the new request. Previously, we would only consider a change in host. Now, we consider any change in host, port or scheme to be a change in origin. Patches Affected Guzzle 7 users should upgrade to Guzzle 7.4.5 as soon as possible. Affected users using any earlier series of Guzzle should upgrade to Guzzle 6.5.8 or 7.4.5. Note that a partial fix was implemented in Guzzle 7.4.2, where a change in host would trigger removal of the curl-added Authorization header, however this earlier fix did not cover change in scheme or change in port. Workarounds If you do…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-25mq-v84q-4j7r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-31090 Advisory: CURLOPT_HTTPAUTH option not cleared on change of origin IDs: CVE-2022-31090, GHSA-25mq-v84q-4j7r Record: https://patchnext.com/advisories/cve-2022-31090 (revision 1, source checked 26 Oct 2026, 14:06 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: guzzlehttp/guzzle 7.4.5, 6.5.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist guzzlehttp/guzzle: affected < 6.5.8; >= 7.0.0, < 7.4.5; fixed in 7.4.5, 6.5.8 ## Suggested inspection (read-only) - Packagist guzzlehttp/guzzle: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on guzzlehttp/guzzle. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-25mq-v84q-4j7r (GitHub-reviewed advisory GHSA-25mq-v84q-4j7r lists affected ranges: Packagist guzzlehttp/guzzle >=0 =7.0.0 <7.4.5) Commands are suggestions: review each one before running it.
Loading voting…