Skip to content

← Actionable
High, CVSS 8.6amended

Authentication bypass vulnerability in Apple Game Center auth adapter

CVE-2022-31083GHSA-rh9j-f5f8-rvgc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 5.2.2, 4.10.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm parse-server

    Affected
    < 4.10.11>= 5.0.0, < 5.2.2
    Fixed in
    4.10.11, 5.2.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N
EPSS
  • CVE-2022-31083: 0.89% estimated exploitation activity in the next 30 days; percentile 59.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The certificate in Apple Game Center auth adapter not validated. As a result, authentication could potentially be bypassed by making a fake certificate accessible via certain Apple domains and providing the URL to that certificate in an authData object. Patches To prevent this, a new rootCertificateUrl property is introduced to the Parse Server Apple Game Center auth adapter which takes the URL to the root certificate of Apple's Game Center authentication certificate. If no value is set, the rootCertificateUrl property defaults to the URL of the current root certificate as of May 27, 2022. Keep in mind that the root certificate can change at any time (expected to be announced by Apple) and that it is the developer's responsibility to keep the root certificate URL up-to-date when using the Parse Server Apple Game Center auth adapter. Workarounds None. References - https://github.com/parse-community/parse-server/security/advisories/GHSA-rh9j-f5f8-rvgc -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-rh9j-f5f8-rvgc

  2. Revision 1 · created ·

    Published from osv record GHSA-rh9j-f5f8-rvgc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-31083

Advisory: Authentication bypass vulnerability in Apple Game Center auth adapter
IDs: CVE-2022-31083, GHSA-rh9j-f5f8-rvgc
Record: https://patchnext.com/advisories/cve-2022-31083 (revision 2, source checked 26 Oct 2026, 12:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: parse-server 5.2.2, 4.10.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm parse-server: affected < 4.10.11; >= 5.0.0, < 5.2.2; fixed in 4.10.11, 5.2.2

## Suggested inspection (read-only)
- `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on parse-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-rh9j-f5f8-rvgc (OSV record GHSA-rh9j-f5f8-rvgc lists affected ranges: npm parse-server >=0 =5.0.0 <5.2.2 (fixed))
- Verified: https://github.com/advisories/GHSA-rh9j-f5f8-rvgc (GitHub-reviewed advisory GHSA-rh9j-f5f8-rvgc lists affected ranges: npm parse-server >=0 =5.0.0 <5.2.2)

Commands are suggestions: review each one before running it.

Loading voting…