KubeEdge Cloud Stream and Edge Stream DoS from large stream message
CVE-2022-31079GHSA-wrcr-x4qj-j543
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/kubeedge/kubeedge 1.11.1, 1.10.2, 1.9.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/kubeedge/kubeedge
- Affected
- >= 1.11.0, < 1.11.1>= 1.10.0, < 1.10.2< 1.9.4
- Fixed in
- 1.11.1, 1.9.4, 1.10.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wrcr-x4qj-j543 lists affected ranges: Go github.com/kubeedge/kubeedge >=1.11.0 =1.10.0 =0 <1.9.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.4 · CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2022-31079: 0.70% estimated exploitation activity in the next 30 days; percentile 53.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The Cloud Stream server and the Edge Stream server reads the entire message into memory without imposing a limit on the size of this message. An attacker can exploit this by sending a large message to exhaust memory and cause a DoS. The Cloud Stream server and the Edge Stream server are under DoS attack in this case. The consequence of the exhaustion is that the CloudCore and EdgeCore will be in a denial of service. Only an authenticated user can cause this issue. It will be affected only when users enable cloudStream module in the config file cloudcore.yaml and enable edgeStream module in the config file edgecore.yaml as below. cloudcore.yaml: edgecore.yaml: Patches This bug has been fixed in Kubeedge 1.11.1, 1.10.2, 1.9.4. Users should update to these versions to resolve the issue. Workarounds Disable cloudStream module in the config file cloudcore.yaml and disable edgeStream module in the config file edgecore.yaml, restart process cloudcore and edgecore after modification.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-wrcr-x4qj-j543
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-31079 Advisory: KubeEdge Cloud Stream and Edge Stream DoS from large stream message IDs: CVE-2022-31079, GHSA-wrcr-x4qj-j543 Record: https://patchnext.com/advisories/cve-2022-31079 (revision 1, source checked 26 Oct 2026, 14:58 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/kubeedge/kubeedge 1.11.1, 1.10.2, 1.9.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/kubeedge/kubeedge: affected >= 1.11.0, < 1.11.1; >= 1.10.0, < 1.10.2; < 1.9.4; fixed in 1.11.1, 1.9.4, 1.10.2 ## Suggested inspection (read-only) - Go github.com/kubeedge/kubeedge: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/kubeedge/kubeedge. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-wrcr-x4qj-j543 (GitHub-reviewed advisory GHSA-wrcr-x4qj-j543 lists affected ranges: Go github.com/kubeedge/kubeedge >=1.11.0 =1.10.0 =0 <1.9.4) Commands are suggestions: review each one before running it.
Loading voting…