Skip to content

← Actionable
Medium, CVSS 4.4

KubeEdge CloudCore Router memory exhaustion vulnerability

CVE-2022-31078GHSA-qpx3-9565-5xwm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/kubeedge/kubeedge 1.11.1, 1.10.2, 1.9.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.4 · CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2022-31078: 0.70% estimated exploitation activity in the next 30 days; percentile 53.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The CloudCore Router does not impose a limit on the size of responses to requests made by the REST handler. An attacker could use this weakness to make a request that will return an HTTP response with a large body and cause DoS of CloudCore. In the HTTP Handler API, the rest handler makes a request to a pre-specified handle. The handle will return an HTTP response that is then read into memory. The consequence of the exhaustion is that CloudCore will be in a denial of service. Only an authenticated user of the cloud can make an attack. It will be affected only when users enable router module in the config file cloudcore.yaml as below. Patches This bug has been fixed in Kubeedge 1.11.1, 1.10.2, 1.9.4. Users should update to these versions to resolve the issue. Workarounds Disable the router module in the config file cloudcore.yaml. References NA Credits Thanks David Korczynski and Adam Korczynski of ADA Logics for responsibly disclosing this issue in accordance with the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-qpx3-9565-5xwm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-31078

Advisory: KubeEdge CloudCore Router memory exhaustion vulnerability
IDs: CVE-2022-31078, GHSA-qpx3-9565-5xwm
Record: https://patchnext.com/advisories/cve-2022-31078 (revision 1, source checked 26 Oct 2026, 14:58 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/kubeedge/kubeedge 1.11.1, 1.10.2, 1.9.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/kubeedge/kubeedge: affected >= 1.11.0, < 1.11.1; >= 1.10.0, < 1.10.2; < 1.9.4; fixed in 1.11.1, 1.9.4, 1.10.2

## Suggested inspection (read-only)
- Go github.com/kubeedge/kubeedge: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/kubeedge/kubeedge.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qpx3-9565-5xwm (GitHub-reviewed advisory GHSA-qpx3-9565-5xwm lists affected ranges: Go github.com/kubeedge/kubeedge >=1.11.0 =1.10.0 =0 <1.9.4)

Commands are suggestions: review each one before running it.

Loading voting…