Skip to content

← Actionable
Medium, CVSS 4.2

CloudCore UDS Server: Malicious Message can crash CloudCore

CVE-2022-31076GHSA-8f4f-v9x5-cg6j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/kubeedge/kubeedge 1.10.1, 1.9.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.2 · CVSS:3.1/AV:A/AC:H/PR:H/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2022-31076: 0.61% estimated exploitation activity in the next 30 days; percentile 49.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A malicious message can crash CloudCore by triggering a null-pointer dereference in the UDS Server. Since the UDS Server only communicates with the CSI Driver on the cloud side, the attack is limited to the local host network. As such, an attacker would already need to be an authenticated user of the Cloud. It will be affected only when users turn on the unixsocket switch in the config file cloudcore.yaml as below: Patches This bug has been fixed in Kubeedge 1.11.0, 1.10.1, and 1.9.3. Users should update to these versions to resolve the issue. Workarounds Disable the unixsocket switch of CloudHub in the config file cloudcore.yaml. References NA Credits Thanks David Korczynski and Adam Korczynski of ADA Logics for responsibly disclosing this issue in accordance with the kubeedge security policy during a security audit sponsored by CNCF and facilitated by OSTIF. For more information If you have any questions or comments about this advisory: Open an issue in KubeEdge repo To make…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-8f4f-v9x5-cg6j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-31076

Advisory: CloudCore UDS Server: Malicious Message can crash CloudCore
IDs: CVE-2022-31076, GHSA-8f4f-v9x5-cg6j
Record: https://patchnext.com/advisories/cve-2022-31076 (revision 1, source checked 26 Oct 2026, 14:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/kubeedge/kubeedge 1.10.1, 1.9.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/kubeedge/kubeedge: affected >= 1.10.0, <= 1.10.0; < 1.9.3; fixed in 1.10.1, 1.9.3

## Suggested inspection (read-only)
- Go github.com/kubeedge/kubeedge: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/kubeedge/kubeedge.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8f4f-v9x5-cg6j (GitHub-reviewed advisory GHSA-8f4f-v9x5-cg6j lists affected ranges: Go github.com/kubeedge/kubeedge >=1.10.0 =0 <1.9.3)

Commands are suggestions: review each one before running it.

Loading voting…