Skip to content

← Actionable
Medium, CVSS 6.5

KubeEdge Edge ServiceBus module DoS

CVE-2022-31073GHSA-vwm6-qc77-v2rh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/kubeedge/kubeedge 1.11.1, 1.10.2, 1.9.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2022-31073: 1.68% estimated exploitation activity in the next 30 days; percentile 76.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The ServiceBus server on the edge side may be susceptible to a DoS attack if an HTTP request containing a very large Body is sent to it. It is possible for the node to be exhausted of memory. The consequence of the exhaustion is that other services on the node, e.g. other containers, will be unable to allocate memory and thus causing a denial of service. Malicious Apps which by accident pulled by users on the host and have the access to send HTTP requests to localhost may make an attack. It will be affected only when users enable the ServiceBus module in the config file edgecore.yaml as below: Patches This bug has been fixed in Kubeedge 1.11.1, 1.10.2, 1.9.4. Users should update to these versions to resolve the issue. Workarounds Disable the ServiceBus module in the config file edgecore.yaml. References NA Credits Thanks David Korczynski and Adam Korczynski of ADA Logics for responsibly disclosing this issue in accordance with the kubeedge security policy during a security…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-vwm6-qc77-v2rh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-31073

Advisory: KubeEdge Edge ServiceBus module DoS
IDs: CVE-2022-31073, GHSA-vwm6-qc77-v2rh
Record: https://patchnext.com/advisories/cve-2022-31073 (revision 1, source checked 26 Oct 2026, 14:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/kubeedge/kubeedge 1.11.1, 1.10.2, 1.9.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/kubeedge/kubeedge: affected >= 1.11.0, < 1.11.1; >= 1.10.0, < 1.10.2; < 1.9.4; fixed in 1.11.1, 1.9.4, 1.10.2

## Suggested inspection (read-only)
- Go github.com/kubeedge/kubeedge: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/kubeedge/kubeedge.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vwm6-qc77-v2rh (GitHub-reviewed advisory GHSA-vwm6-qc77-v2rh lists affected ranges: Go github.com/kubeedge/kubeedge >=1.11.0 =1.10.0 =0 <1.9.4)

Commands are suggestions: review each one before running it.

Loading voting…