Skip to content

← Actionable
Low, CVSS 2.5

Octopoller gem published with world-writable files

CVE-2022-31071GHSA-26qj-cr27-r5c4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (octopoller 0.3.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems octopoller

    Affected
    >= 0.2.0, <= 0.2.0
    Fixed in
    0.3.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
2.5 · CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N
EPSS
  • CVE-2022-31071: 0.22% estimated exploitation activity in the next 30 days; percentile 12.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Version 0.2.0 of the octopoller gem was published containing world-writeable files. Specifically, the gem was packed with files having their permissions set to -rw-rw-rw- (i.e. 0666) instead of rw-r--r-- (i.e. 0644). This means everyone who is not the owner (Group and Public) with access to the instance where this release had been installed could modify the world-writable files from this gem. Malicious code already present and running on your machine, separate from this package, could modify the gem’s files and change its behavior during runtime. Patches octopoller 0.3.0 Workarounds Users can use the previous version of the gem v0.1.0. Alternatively, users can modify the file permissions manually until they are able to upgrade to the latest version.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-26qj-cr27-r5c4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-31071

Advisory: Octopoller gem published with world-writable files
IDs: CVE-2022-31071, GHSA-26qj-cr27-r5c4
Record: https://patchnext.com/advisories/cve-2022-31071 (revision 1, source checked 26 Oct 2026, 15:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: octopoller 0.3.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems octopoller: affected >= 0.2.0, <= 0.2.0; fixed in 0.3.0

## Suggested inspection (read-only)
- RubyGems octopoller: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on octopoller.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-26qj-cr27-r5c4 (GitHub-reviewed advisory GHSA-26qj-cr27-r5c4 lists affected ranges: RubyGems octopoller >=0.2.0 <=0.2.0)

Commands are suggestions: review each one before running it.

Loading voting…