Potential Authorization Header Exposure in NPM Packages @finastra/nestjs-proxy, @ffdc/nestjs-proxy
CVE-2022-31069GHSA-j562-c3cw-3p5g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@finastra/nestjs-proxy 0.7.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 0.7.0
- Fixed in
- 0.7.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-j562-c3cw-3p5g lists affected ranges: npm @finastra/nestjs-proxy >=0 <0.7.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j562-c3cw-3p5g lists affected ranges: npm @finastra/nestjs-proxy >=0 <0.7.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.8 · CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:N
- EPSS
- CVE-2022-31069: 0.65% estimated exploitation activity in the next 30 days; percentile 51.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The nestjs-proxy library did not have a way to control when Authorization headers should should be forwarded for specific backend services configured by the application developer. This could have resulted in sensitive information such as OAuth bearer access tokens being inadvertently exposed to such services that should not see them. A new feature has been introduced in the patched version of nestjs-proxy that allows application developers to opt out of forwarding the Authorization headers on a per service basis using the forwardToken config setting. Developers are advised to review the README for this library on Github or NPM for further details on how this configuration can be applied. Patches - This issue has been fixed in version 0.7.0 of @finastra/nestjs-proxy. - Users of @ffdc/nestjs-proxy are advised that this package has been deprecated and is no longer being maintained or receiving updates. Please update your package.json file to use @finastra/nestjs-proxy instead.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-j562-c3cw-3p5g
- Revision 1 · created ·
Published from osv record GHSA-j562-c3cw-3p5g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-31069 Advisory: Potential Authorization Header Exposure in NPM Packages @finastra/nestjs-proxy, @ffdc/nestjs-proxy IDs: CVE-2022-31069, GHSA-j562-c3cw-3p5g Record: https://patchnext.com/advisories/cve-2022-31069 (revision 2, source checked 26 Oct 2026, 12:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @finastra/nestjs-proxy 0.7.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @finastra/nestjs-proxy: affected < 0.7.0; fixed in 0.7.0 ## Suggested inspection (read-only) - `npm ls @finastra/nestjs-proxy --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @finastra/nestjs-proxy. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-j562-c3cw-3p5g (OSV record GHSA-j562-c3cw-3p5g lists affected ranges: npm @finastra/nestjs-proxy >=0 <0.7.0 (fixed)) - Verified: https://github.com/advisories/GHSA-j562-c3cw-3p5g (GitHub-reviewed advisory GHSA-j562-c3cw-3p5g lists affected ranges: npm @finastra/nestjs-proxy >=0 <0.7.0) Commands are suggestions: review each one before running it.
Loading voting…