Skip to content

← Actionable
High, CVSS 7.5

Uses of deprecated API can be used to cause DoS in user-facing endpoints

CVE-2022-31054GHSA-5q86-62xr-3r57

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/argoproj/argo-events 1.7.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2022-31054: 1.63% estimated exploitation activity in the next 30 days; percentile 76.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Several HandleRoute endpoints make use of the deprecated ioutil.ReadAll(). ioutil.ReadAll() reads all the data into memory. As such, an attacker who sends a large request to the Argo Events server will be able to crash it and cause denial of service. Eventsources susceptible to an out-of-memory denial-of-service attack: - AWS SNS - Bitbucket - Bitbucket - Gitlab - Slack - Storagegrid - Webhook Patches A patch for this vulnerability has been released in the following Argo Events version: v1.7.1 Credits Disclosed by Ada Logics in a security audit sponsored by CNCF and facilitated by OSTIF. For more information Open an issue in the Argo Events issue tracker or discussions Join us on Slack in channel #argo-events

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-5q86-62xr-3r57

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-31054

Advisory: Uses of deprecated API can be used to cause DoS in user-facing endpoints
IDs: CVE-2022-31054, GHSA-5q86-62xr-3r57
Record: https://patchnext.com/advisories/cve-2022-31054 (revision 1, source checked 26 Oct 2026, 14:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/argoproj/argo-events 1.7.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/argoproj/argo-events: affected < 1.7.1; fixed in 1.7.1

## Suggested inspection (read-only)
- Go github.com/argoproj/argo-events: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/argoproj/argo-events.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5q86-62xr-3r57 (GitHub-reviewed advisory GHSA-5q86-62xr-3r57 lists affected ranges: Go github.com/argoproj/argo-events >=0 <1.7.1)

Commands are suggestions: review each one before running it.

Loading voting…