Skip to content

← Actionable
High, CVSS 7.1amended

URL previews of unusual or maliciously-crafted pages can crash Synapse media repositories or Synapse monoliths

CVE-2022-31052GHSA-22p3-qrh9-cx32

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (matrix-synapse 1.61.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2022-31052: 1.66% estimated exploitation activity in the next 30 days; percentile 76.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact URL previews of some web pages can exhaust the available stack space for the Synapse process due to unbounded recursion. This is sometimes recoverable and leads to an error for the request causing the problem, but in other cases the Synapse process may crash altogether. It is possible to exploit this maliciously, either by malicious users on the homeserver, or by remote users sending URLs that a local user's client may automatically request a URL preview for. Remote users are not able to exploit this directly, because the URL preview endpoint is authenticated. Am I affected? deployments with urlpreviewenabled: false set in configuration are not affected. deployments with urlpreviewenabled: true set in configuration are affected. deployments with no configuration value set for urlpreviewenabled are not affected, because the default is false. Patches Administrators of homeservers with URL previews enabled are advised to upgrade to v1.61.1 or higher. Workarounds URL previews can…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-22p3-qrh9-cx32

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-22p3-qrh9-cx32

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-31052

Advisory: URL previews of unusual or maliciously-crafted pages can crash Synapse media repositories or Synapse monoliths
IDs: CVE-2022-31052, GHSA-22p3-qrh9-cx32
Record: https://patchnext.com/advisories/cve-2022-31052 (revision 3, source checked 26 Oct 2026, 13:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: matrix-synapse 1.61.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI matrix-synapse: affected < 1.61.1; fixed in 1.61.1

## Suggested inspection (read-only)
- `python -m pip show matrix-synapse`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on matrix-synapse.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-22p3-qrh9-cx32 (OSV record GHSA-22p3-qrh9-cx32 lists affected ranges: PyPI matrix-synapse >=0 <1.61.1 (fixed))
- Verified: https://github.com/advisories/GHSA-22p3-qrh9-cx32 (GitHub-reviewed advisory GHSA-22p3-qrh9-cx32 lists affected ranges: PyPI matrix-synapse >=0 <1.61.1)

Commands are suggestions: review each one before running it.

Loading voting…