Skip to content

← Actionable
Medium, CVSS 4.3

Symlink following allows leaking out-of-bounds YAML files from Argo CD repo-server

CVE-2022-31036GHSA-q4w5-4gq2-98vm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/argoproj/argo-cd/v2 2.4.1, 2.3.5, 2.2.10, 2.1.16; github.com/argoproj/argo-cd 2.1.16), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2022-31036: 0.89% estimated exploitation activity in the next 30 days; percentile 59.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact All unpatched versions of Argo CD starting with v1.3.0 are vulnerable to a symlink following bug allowing a malicious user with repository write access to leak sensitive YAML files from Argo CD's repo-server. A malicious Argo CD user with write access for a repository which is (or may be) used in a Helm-type Application may commit a symlink which points to an out-of-bounds file. If the target file is a valid YAML file, the attacker can read the contents of that file. Sensitive files which could be leaked include manifest files from other Applications' source repositories (potentially decrypted files, if you are using a decryption plugin) or any YAML-formatted secrets which have been mounted as files on the repo-server. Patches A patch for this vulnerability has been released in the following Argo CD versions: v2.4.1 v2.3.5 v2.2.10 v2.1.16 Workarounds If you are using =v2.3.0 and do not have any Helm-type Applications, disable the Helm config management tool. Mitigations Avoid…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-q4w5-4gq2-98vm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-31036

Advisory: Symlink following allows leaking out-of-bounds YAML files from Argo CD repo-server
IDs: CVE-2022-31036, GHSA-q4w5-4gq2-98vm
Record: https://patchnext.com/advisories/cve-2022-31036 (revision 1, source checked 26 Oct 2026, 14:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/argoproj/argo-cd/v2 2.4.1, 2.3.5, 2.2.10, 2.1.16; github.com/argoproj/argo-cd 2.1.16. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/argoproj/argo-cd/v2: affected < 2.1.16; >= 2.2.0, < 2.2.10; >= 2.3.0, < 2.3.5; >= 2.4.0, <= 2.4.0; fixed in 2.4.1, 2.2.10, 2.3.5, 2.1.16
- Go github.com/argoproj/argo-cd: affected >= 1.3.0, <= 1.8.7; fixed in 2.1.16

## Suggested inspection (read-only)
- Go github.com/argoproj/argo-cd/v2: check the installed version with your package manager.
- Go github.com/argoproj/argo-cd: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/argoproj/argo-cd/v2, github.com/argoproj/argo-cd.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-q4w5-4gq2-98vm (GitHub-reviewed advisory GHSA-q4w5-4gq2-98vm lists affected ranges: Go github.com/argoproj/argo-cd >=1.3.0 =0 =2.2.0 =2.3.0 =2.4.0 <=2.4.0)

Commands are suggestions: review each one before running it.

Loading voting…