Skip to content

← Actionable
High, CVSS 8.3

Insecure entropy in Argo CD's PKCE/Oauth2/OIDC params

CVE-2022-31034GHSA-2m7h-86qq-fp4v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/argoproj/argo-cd/v2 2.4.1, 2.3.5, 2.2.10, 2.1.16; github.com/argoproj/argo-cd 2.1.16), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.3 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H
EPSS
  • CVE-2022-31034: 0.96% estimated exploitation activity in the next 30 days; percentile 61.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact All versions of Argo CD starting with v0.11.0 are vulnerable to a variety of attacks when an SSO login is initiated from the Argo CD CLI or UI. The vulnerabilities are due to the use of insufficiently random values in parameters in Oauth2/OIDC login flows. In each case, using a relatively-predictable (time-based) seed in a non-cryptographically-secure pseudo-random number generator made the parameter less random than required by the relevant spec or by general best practices. In some cases, using too short a value made the entropy even less sufficient. (The specific weak parameters are listed in the References section.) The attacks on login flows which are meant to be mitigated by these parameters are difficult to accomplish but can have a high impact (potentially granting an attacker admin access to Argo CD). The CVSS for this Security Advisory assumes the worst-case scenario. Patches A patch for this vulnerability has been released in the following Argo CD versions: v2.4.1…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-2m7h-86qq-fp4v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-31034

Advisory: Insecure entropy in Argo CD's PKCE/Oauth2/OIDC params
IDs: CVE-2022-31034, GHSA-2m7h-86qq-fp4v
Record: https://patchnext.com/advisories/cve-2022-31034 (revision 1, source checked 26 Oct 2026, 14:58 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/argoproj/argo-cd/v2 2.4.1, 2.3.5, 2.2.10, 2.1.16; github.com/argoproj/argo-cd 2.1.16. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/argoproj/argo-cd/v2: affected < 2.1.16; >= 2.2.0, < 2.2.10; >= 2.3.0, < 2.3.5; >= 2.4.0, <= 2.4.0; fixed in 2.4.1, 2.2.10, 2.3.5, 2.1.16
- Go github.com/argoproj/argo-cd: affected >= 0.11.0, <= 1.8.7; fixed in 2.1.16

## Suggested inspection (read-only)
- Go github.com/argoproj/argo-cd/v2: check the installed version with your package manager.
- Go github.com/argoproj/argo-cd: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/argoproj/argo-cd/v2, github.com/argoproj/argo-cd.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-2m7h-86qq-fp4v (GitHub-reviewed advisory GHSA-2m7h-86qq-fp4v lists affected ranges: Go github.com/argoproj/argo-cd >=0.11.0 =0 =2.2.0 =2.3.0 =2.4.0 <=2.4.0)

Commands are suggestions: review each one before running it.

Loading voting…