Skip to content

← Actionable
Medium, CVSS 5.9

Mechanize before v2.8.5 vulnerable to authorization header leak on port redirect

CVE-2022-31033GHSA-64qm-hrgp-pgr9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mechanize 2.8.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems mechanize

    Affected
    < 2.8.5
    Fixed in
    2.8.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2022-31033: 1.52% estimated exploitation activity in the next 30 days; percentile 74.67 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Mechanize (rubygem) < v2.8.5 leaks the Authorization header after a redirect to a different port on the same site. Mitigation Upgrade to Mechanize v2.8.5 or later. Notes See https://curl.se/docs/CVE-2022-27776.html for a similar vulnerability in curl. Cookies are shared with a server at a different port on the same site, per https://datatracker.ietf.org/doc/html/rfc6265#section-8.5 which states in part: Cookies do not provide isolation by port. If a cookie is readable by a service running on one port, the cookie is also readable by a service running on another port of the same server. If a cookie is writable by a service on one port, the cookie is also writable by a service running on another port of the same server. For this reason, servers SHOULD NOT both run mutually distrusting services on different ports of the same host and use cookies to store security- sensitive information.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-64qm-hrgp-pgr9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-31033

Advisory: Mechanize before v2.8.5 vulnerable to authorization header leak on port redirect
IDs: CVE-2022-31033, GHSA-64qm-hrgp-pgr9
Record: https://patchnext.com/advisories/cve-2022-31033 (revision 1, source checked 26 Oct 2026, 15:44 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mechanize 2.8.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems mechanize: affected < 2.8.5; fixed in 2.8.5

## Suggested inspection (read-only)
- RubyGems mechanize: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mechanize.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-64qm-hrgp-pgr9 (GitHub-reviewed advisory GHSA-64qm-hrgp-pgr9 lists affected ranges: RubyGems mechanize >=0 <2.8.5)

Commands are suggestions: review each one before running it.

Loading voting…