containerd CRI plugin: Host memory exhaustion through ExecSync
CVE-2022-31030GHSA-5ffw-gxpp-mxpf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/containerd/containerd 1.6.6, 1.5.13), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/containerd/containerd
- Affected
- < 1.5.13>= 1.6.0, < 1.6.6
- Fixed in
- 1.5.13, 1.6.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5ffw-gxpp-mxpf lists affected ranges: Go github.com/containerd/containerd >=0 =1.6.0 <1.6.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.5 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2022-31030: 0.39% estimated exploitation activity in the next 30 days; percentile 32.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A bug was found in containerd's CRI implementation where programs inside a container can cause the containerd daemon to consume memory without bound during invocation of the ExecSync API. This can cause containerd to consume all available memory on the computer, denying service to other legitimate workloads. Kubernetes and crictl can both be configured to use containerd's CRI implementation; ExecSync may be used when running probes or when executing processes via an "exec" facility. Patches This bug has been fixed in containerd 1.6.6 and 1.5.13. Users should update to these versions to resolve the issue. Workarounds Ensure that only trusted images and commands are used. References Similar fix in cri-o's CRI implementation https://github.com/cri-o/cri-o/security/advisories/GHSA-fcm2-6c3h-pg6j Credits The containerd project would like to thank David Korczynski and Adam Korczynski of ADA Logics for responsibly disclosing this issue in accordance with the containerd security…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5ffw-gxpp-mxpf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-31030 Advisory: containerd CRI plugin: Host memory exhaustion through ExecSync IDs: CVE-2022-31030, GHSA-5ffw-gxpp-mxpf Record: https://patchnext.com/advisories/cve-2022-31030 (revision 1, source checked 26 Oct 2026, 15:03 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/containerd/containerd 1.6.6, 1.5.13. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/containerd/containerd: affected < 1.5.13; >= 1.6.0, < 1.6.6; fixed in 1.5.13, 1.6.6 ## Suggested inspection (read-only) - Go github.com/containerd/containerd: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/containerd/containerd. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5ffw-gxpp-mxpf (GitHub-reviewed advisory GHSA-5ffw-gxpp-mxpf lists affected ranges: Go github.com/containerd/containerd >=0 =1.6.0 <1.6.6) Commands are suggestions: review each one before running it.
Loading voting…