Skip to content

← Actionable
Medium, CVSS 5.9

Use of Uninitialized Variable in trilogy

CVE-2022-31026GHSA-5g4r-2qhx-vqfm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (trilogy 2.1.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems trilogy

    Affected
    < 2.1.1
    Fixed in
    2.1.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2022-31026: 1.09% estimated exploitation activity in the next 30 days; percentile 65.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact When authenticating, a malicious server could return a specially crafted authentication packet, causing the client to read and return up to 12 bytes of data from an uninitialized variable in stack memory. Patches Users of the trilogy gem should upgrade to version 2.1.1 Workarounds This issue can be avoided by only connecting to trusted servers. Acknowledgements We would like to thank Sergei Volokitin for reporting this vulnerability For more information If you have any questions or comments about this advisory: Open an issue in trilogy

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-5g4r-2qhx-vqfm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-31026

Advisory: Use of Uninitialized Variable in trilogy
IDs: CVE-2022-31026, GHSA-5g4r-2qhx-vqfm
Record: https://patchnext.com/advisories/cve-2022-31026 (revision 1, source checked 26 Oct 2026, 15:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: trilogy 2.1.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems trilogy: affected < 2.1.1; fixed in 2.1.1

## Suggested inspection (read-only)
- RubyGems trilogy: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on trilogy.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5g4r-2qhx-vqfm (GitHub-reviewed advisory GHSA-5g4r-2qhx-vqfm lists affected ranges: RubyGems trilogy >=0 <2.1.1)

Commands are suggestions: review each one before running it.

Loading voting…