Skip to content

← Actionable
High, CVSS 7.1amended

Indy's NODE_UPGRADE transaction vulnerable to remote code execution

CVE-2022-31020GHSA-r6v9-p59m-gj2p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (indy-node 1.12.5rc1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI indy-node

    Affected
    < 1.12.5rc1
    Fixed in
    1.12.5rc1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2022-31020: 2.31% estimated exploitation activity in the next 30 days; percentile 83.38 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The pool-upgrade request handler in Indy-Node <=1.12.4 allows an improperly authenticated attacker to remotely execute code on nodes within the network. Network operators are strongly encouraged to upgrade to the latest Indy-Node release =1.12.5 as soon as possible. Patches The pool-upgrade request handler in Indy-Node =1.12.5 has been updated to properly authenticate pool-upgrade transactions before any processing is performed by the request handler. The transactions are further sanitized to prevent remote code execution. Mitigations Network operators are strongly encouraged to upgrade to the latest Indy-Node release =1.12.5 as soon as possible. Acknowledgements Thank you to @shakreiner at CyberArk Labs for finding and responsibly disclosing this issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-r6v9-p59m-gj2p

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-r6v9-p59m-gj2p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-31020

Advisory: Indy's NODE_UPGRADE transaction vulnerable to remote code execution
IDs: CVE-2022-31020, GHSA-r6v9-p59m-gj2p
Record: https://patchnext.com/advisories/cve-2022-31020 (revision 3, source checked 26 Oct 2026, 13:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: indy-node 1.12.5rc1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI indy-node: affected < 1.12.5rc1; fixed in 1.12.5rc1

## Suggested inspection (read-only)
- `python -m pip show indy-node`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on indy-node.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-r6v9-p59m-gj2p (OSV record GHSA-r6v9-p59m-gj2p lists affected ranges: PyPI indy-node >=0 <1.12.5rc1 (fixed))
- Verified: https://github.com/advisories/GHSA-r6v9-p59m-gj2p (GitHub-reviewed advisory GHSA-r6v9-p59m-gj2p lists affected ranges: PyPI indy-node >=0 <1.12.5rc1)

Commands are suggestions: review each one before running it.

Loading voting…