Skip to content

← Actionable
High, CVSS 7.5

Denial of service binding form from JSON in Play Framework

CVE-2022-31018GHSA-v8x6-59g4-5g3w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.typesafe.play:play_2.12 2.8.16; com.typesafe.play:play_2.13 2.8.16), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2022-31018: 1.72% estimated exploitation activity in the next 30 days; percentile 77.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A denial-of-service vulnerability has been discovered in Play's forms library, in both the Scala and Java APIs. This can occur when using either the Form#bindFromRequest method on a JSON request body or the Form#bind method directly on a JSON value. If the JSON data being bound to the form contains a deeply-nested JSON object or array, the form binding implementation may consume all available heap space and cause an OutOfMemoryError. If executing on the default dispatcher and akka.jvm-exit-on-fatal-error is enabled—as it is by default—then this can crash the application process. Form.bindFromRequest is vulnerable when using any body parser that produces a type of AnyContent or JsValue in Scala, or one that can produce a JsonNode in Java. This includes Play's default body parser. Patches This vulnerability been patched in version 2.8.16. There is now a global limit on the depth of a JSON object that can be parsed, which can be configured by the user if necessary. Workarounds…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-v8x6-59g4-5g3w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-31018

Advisory: Denial of service binding form from JSON in Play Framework
IDs: CVE-2022-31018, GHSA-v8x6-59g4-5g3w
Record: https://patchnext.com/advisories/cve-2022-31018 (revision 1, source checked 26 Oct 2026, 16:01 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: com.typesafe.play:play_2.12 2.8.16; com.typesafe.play:play_2.13 2.8.16. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven com.typesafe.play:play_2.12: affected >= 2.8.3, < 2.8.16; fixed in 2.8.16
- Maven com.typesafe.play:play_2.13: affected >= 2.8.3, < 2.8.16; fixed in 2.8.16

## Suggested inspection (read-only)
- Maven com.typesafe.play:play_2.12: check the installed version with your package manager.
- Maven com.typesafe.play:play_2.13: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on com.typesafe.play:play_2.12, com.typesafe.play:play_2.13.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-v8x6-59g4-5g3w (GitHub-reviewed advisory GHSA-v8x6-59g4-5g3w lists affected ranges: Maven com.typesafe.play:play_2.13 >=2.8.3 =2.8.3 <2.8.16)

Commands are suggestions: review each one before running it.

Loading voting…