Regular expression denial of service in apache tika
CVE-2022-30973GHSA-qw3f-w4pf-jh5f
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.tika:tika-core 1.28.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.tika:tika-core
- Affected
- >= 1.17, < 1.28.3
- Fixed in
- 1.28.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qw3f-w4pf-jh5f lists affected ranges: Maven org.apache.tika:tika-core >=1.17 <1.28.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.5 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
- EPSS
- CVE-2022-30973: 1.98% estimated exploitation activity in the next 30 days; percentile 80.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
We failed to apply the fix for CVE-2022-30126 to the 1.x branch in the 1.28.2 release. In Apache Tika, a regular expression in the StandardsText class, used by the StandardsExtractingContentHandler could lead to a denial of service caused by backtracking on a specially crafted file. This only affects users who are running the StandardsExtractingContentHandler, which is a non-standard handler. This is fixed in 1.28.3.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-qw3f-w4pf-jh5f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-30973 Advisory: Regular expression denial of service in apache tika IDs: CVE-2022-30973, GHSA-qw3f-w4pf-jh5f Record: https://patchnext.com/advisories/cve-2022-30973 (revision 1, source checked 26 Oct 2026, 16:12 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.tika:tika-core 1.28.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.tika:tika-core: affected >= 1.17, < 1.28.3; fixed in 1.28.3 ## Suggested inspection (read-only) - Maven org.apache.tika:tika-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.tika:tika-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-qw3f-w4pf-jh5f (GitHub-reviewed advisory GHSA-qw3f-w4pf-jh5f lists affected ranges: Maven org.apache.tika:tika-core >=1.17 <1.28.3) Commands are suggestions: review each one before running it.
Loading voting…