Insufficiently Protected Credentials in Jenkins Pipeline SCM API for Blue Ocean Plugin
CVE-2022-30952GHSA-g74w-93cp-5p3p
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.jenkins.blueocean:blueocean-pipeline-scm-api 1.25.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven io.jenkins.blueocean:blueocean-pipeline-scm-api
- Affected
- < 1.25.4
- Fixed in
- 1.25.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g74w-93cp-5p3p lists affected ranges: Maven io.jenkins.blueocean:blueocean-pipeline-scm-api >=0 <1.25.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2022-30952: 1.02% estimated exploitation activity in the next 30 days; percentile 63.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
When pipelines are created using the pipeline creation wizard in Blue Ocean, the credentials used are stored in the per-user credentials store of the user creating the pipeline. To allow pipelines to use this credential to scan repositories and checkout from SCM, the Blue Ocean Credentials Provider allows pipelines to access a specific credential from the per-user credentials store in Pipeline SCM API for Blue Ocean Plugin 1.25.3 and earlier. As a result, attackers with Job/Configure permission can rewrite job configurations in a way that lets them access and capture any attacker-specified credential from any user’s private credentials store. Pipeline SCM API for Blue Ocean Plugin 1.25.4 deprecates the Blue Ocean Credentials Provider and disables it by default. As a result, all jobs initially set up using the Blue Ocean pipeline creation wizard and configured to use the credential specified at that time will no longer be able to access the credential, resulting in failures to scan…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-g74w-93cp-5p3p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-30952 Advisory: Insufficiently Protected Credentials in Jenkins Pipeline SCM API for Blue Ocean Plugin IDs: CVE-2022-30952, GHSA-g74w-93cp-5p3p Record: https://patchnext.com/advisories/cve-2022-30952 (revision 1, source checked 26 Oct 2026, 16:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: io.jenkins.blueocean:blueocean-pipeline-scm-api 1.25.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven io.jenkins.blueocean:blueocean-pipeline-scm-api: affected < 1.25.4; fixed in 1.25.4 ## Suggested inspection (read-only) - Maven io.jenkins.blueocean:blueocean-pipeline-scm-api: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on io.jenkins.blueocean:blueocean-pipeline-scm-api. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-g74w-93cp-5p3p (GitHub-reviewed advisory GHSA-g74w-93cp-5p3p lists affected ranges: Maven io.jenkins.blueocean:blueocean-pipeline-scm-api >=0 <1.25.4) Commands are suggestions: review each one before running it.
Loading voting…