Improper Removal of Sensitive Information Before Storage or Transfer in Strapi
CVE-2022-30617GHSA-f6fm-r26q-p747
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (strapi 3.6.9; @strapi/strapi 4.0.0-beta.15), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm strapi
- Affected
- >= 3.0.0, < 3.6.9
- Fixed in
- 3.6.9
npm @strapi/strapi
- Affected
- <= 4.0.0-beta.14
- Fixed in
- 4.0.0-beta.15
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-f6fm-r26q-p747 lists affected ranges: npm strapi >=3.0.0 =0 <4.0.0-beta.15 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f6fm-r26q-p747 lists affected ranges: npm strapi >=3.0.0 =0 <=4.0.0-beta.14
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-30617: 1.47% estimated exploitation activity in the next 30 days; percentile 73.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An authenticated user with access to the Strapi admin panel can view private and sensitive data, such as email and password reset tokens, for other admin panel users that have a relationship (e.g., created by, updated by) with content accessible to the authenticated user. For example, a low-privileged “author” role account can view these details in the JSON response for an “editor” or “super admin” that has updated one of the author’s blog posts. There are also many other scenarios where such details from other users can leak in the JSON response, either through a direct or indirect relationship. Access to this information enables a user to compromise other users’ accounts by successfully invoking the password reset workflow. In a worst-case scenario, a low-privileged user could get access to a “super admin” account with full control over the Strapi instance, and could read and modify any data as well as block access to both the admin panel and API by revoking privileges for all…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-f6fm-r26q-p747
- Revision 1 · created ·
Published from osv record GHSA-f6fm-r26q-p747
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-30617 Advisory: Improper Removal of Sensitive Information Before Storage or Transfer in Strapi IDs: CVE-2022-30617, GHSA-f6fm-r26q-p747 Record: https://patchnext.com/advisories/cve-2022-30617 (revision 2, source checked 26 Oct 2026, 12:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: strapi 3.6.9; @strapi/strapi 4.0.0-beta.15. A vendor fix does not mean a deployment is fixed. ## Affected components - npm strapi: affected >= 3.0.0, < 3.6.9; fixed in 3.6.9 - npm @strapi/strapi: affected <= 4.0.0-beta.14; fixed in 4.0.0-beta.15 ## Suggested inspection (read-only) - `npm ls strapi --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @strapi/strapi --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on strapi, @strapi/strapi. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-f6fm-r26q-p747 (OSV record GHSA-f6fm-r26q-p747 lists affected ranges: npm strapi >=3.0.0 =0 <4.0.0-beta.15 (fixed)) - Verified: https://github.com/advisories/GHSA-f6fm-r26q-p747 (GitHub-reviewed advisory GHSA-f6fm-r26q-p747 lists affected ranges: npm strapi >=3.0.0 =0 <=4.0.0-beta.14) Commands are suggestions: review each one before running it.
Loading voting…