Skip to content

← Actionable
Medium, CVSS 5.3

External Control of Assumed-Immutable Web Parameter in moodle

CVE-2022-30597GHSA-x6gm-qqwp-76gr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (moodle/moodle 4.0.1, 3.11.7, 3.10.11, 3.9.14), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist moodle/moodle

    Affected
    >= 4.0, < 4.0.1>= 3.11, < 3.11.7>= 3.10, < 3.10.11>= 3.9, < 3.9.14
    Fixed in
    3.11.7, 3.10.11, 3.9.14, 4.0.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2022-30597: 1.33% estimated exploitation activity in the next 30 days; percentile 71.03 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A flaw was found in moodle where the description user field was not hidden when being set as a hidden user field.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-x6gm-qqwp-76gr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-30597

Advisory: External Control of Assumed-Immutable Web Parameter in moodle
IDs: CVE-2022-30597, GHSA-x6gm-qqwp-76gr
Record: https://patchnext.com/advisories/cve-2022-30597 (revision 1, source checked 26 Oct 2026, 14:09 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: moodle/moodle 4.0.1, 3.11.7, 3.10.11, 3.9.14. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist moodle/moodle: affected >= 4.0, < 4.0.1; >= 3.11, < 3.11.7; >= 3.10, < 3.10.11; >= 3.9, < 3.9.14; fixed in 3.11.7, 3.10.11, 3.9.14, 4.0.1

## Suggested inspection (read-only)
- Packagist moodle/moodle: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on moodle/moodle.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-x6gm-qqwp-76gr (GitHub-reviewed advisory GHSA-x6gm-qqwp-76gr lists affected ranges: Packagist moodle/moodle >=4.0 =3.11 =3.10 =3.9 <3.9.14)

Commands are suggestions: review each one before running it.

Loading voting…