Privilege escalation in Hashicorp Nomad
CVE-2022-30324GHSA-526x-rm7j-v389
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/hashicorp/nomad 1.3.1, 1.2.8, 1.1.14), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 0.2.0, < 1.1.14>= 1.2.0, < 1.2.8>= 1.3.0, < 1.3.1
- Fixed in
- 1.1.14, 1.2.8, 1.3.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-526x-rm7j-v389 lists affected ranges: Go github.com/hashicorp/nomad >=0.2.0 =1.2.0 =1.3.0 <1.3.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-30324: 1.42% estimated exploitation activity in the next 30 days; percentile 72.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
HashiCorp Nomad and Nomad Enterprise version 0.2.0 up to 1.3.0 were impacted by go-getter vulnerabilities enabling privilege escalation through the artifact stanza in submitted jobs onto the client agent host. Fixed in 1.1.14, 1.2.8, and 1.3.1.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-526x-rm7j-v389
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-30324 Advisory: Privilege escalation in Hashicorp Nomad IDs: CVE-2022-30324, GHSA-526x-rm7j-v389 Record: https://patchnext.com/advisories/cve-2022-30324 (revision 1, source checked 26 Oct 2026, 14:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/hashicorp/nomad 1.3.1, 1.2.8, 1.1.14. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/hashicorp/nomad: affected >= 0.2.0, < 1.1.14; >= 1.2.0, < 1.2.8; >= 1.3.0, < 1.3.1; fixed in 1.1.14, 1.2.8, 1.3.1 ## Suggested inspection (read-only) - Go github.com/hashicorp/nomad: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/hashicorp/nomad. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-526x-rm7j-v389 (GitHub-reviewed advisory GHSA-526x-rm7j-v389 lists affected ranges: Go github.com/hashicorp/nomad >=0.2.0 =1.2.0 =1.3.0 <1.3.1) Commands are suggestions: review each one before running it.
Loading voting…